码迷,mamicode.com
首页 > 其他好文 > 详细

Sicily Online Judge 1438. Shopaholic (快排,隔三求和)

时间:2014-12-01 00:51:01      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

1438. Shopaholic

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the store. You have given up on curing her for this disease, but try to limit its effect on her wallet. You have realized that the stores coming with these offers are quite selective when it comes to which items you get for free; it is always the cheapest ones. As an example, when your friend comes to the counter with seven items, costing 400, 350, 300, 250, 200, 150, and 100 dollars, she will have to pay 1500 dollars. In this case she got a discount of 250 dollars. You realize that if she goes to the counter three times, she might get a bigger discount. E.g. if she goes with the items that costs 400, 300 and 250, she will get a discount of 250 the first round. The next round she brings the item that costs 150 giving no extra discount, but the third round she takes the last items that costs 350, 200 and 100 giving a discount of an additional 100 dollars, adding up to a total discount of 350. Your job is to find the maximum discount Lindsay can get.

Input

The first line of input gives the number of test scenarios, 1 ≤ t ≤ 20. Each scenario consists of two lines of input. The first gives the number of items Lindsay is buying, 1 ≤ n ≤ 20000. The next line gives the prices of these items, 1 ≤ pi ≤ 20000.

Output

For each scenario, output one line giving the maximum discount Lindsay can get by selectively choosing which items she brings to the counter at the same time.

Sample Input

1
6
400 100 200 350 300 250

Sample Output

400

解题思路:

排序需要用快排才不会超时,然后隔三个数求和,基本上是一道水题。趁此机会重新实现了一次快排。

 

源代码:

// Problem#: 1438
// Submission#: 3295603
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <cstdio>
#include <algorithm>

void quickSort(int* p, int s, int e) {
  int key = p[(s + e) / 2];
  int x = s;
  int y = e;
  if (s > e || s < 0 || e < 0) return;
  while (x < y) {
    while (p[x] < key) x++;
    while (p[y] > key) y--;
    if (x <= y) {
      int tmp = p[x];
      p[x] = p[y];
      p[y] = tmp;
      x++; y--;
    }
  }
  if (s < y) quickSort(p, s, y);
  if (x < e) quickSort(p, x, e);
}

int getSum(int *p, int n) {
  int sum = 0;
  for (int i = n - 3; i >= 0; i -= 3) {
    sum += p[i];
  }
  return sum;
}

int main() {
  int t, n;
  int p[20020];

  scanf("%d", &t);
  while (t--) {
    scanf("%d", &n);
    for (int i = 0; i < n; i++) {
      scanf("%d", &p[i]);
    }
    quickSort(p, 0, n - 1);
    printf("%d\n", getSum(p, n));
  }
  return 0;
}                                 

 

Sicily Online Judge 1438. Shopaholic (快排,隔三求和)

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://www.cnblogs.com/wu10022/p/4134052.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!