码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 5113 Black And White DFS+剪枝

时间:2014-12-01 01:06:36      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   


DFS+剪枝...

在每次DFS前,当前棋盘的格子数量的一半小于一种颜色的数量时就剪掉

Black And White

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 194    Accepted Submission(s): 50
Special Judge


Problem Description
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly ci cells.

Matt hopes you can tell him a possible coloring.
 

Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers ci (ci > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c1 + c2 + · · · + cK = N × M .
 

Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1). 

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.
 

Sample Input
4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2
 

Sample Output
Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int n,m,k;
int mp[6][6];

struct CC
{
    int num,color;
}c[30];

int color[30];
int ccc[30];

bool cmp(CC a,CC b)
{
    return a.num<b.num;
}

bool flag;

bool inside(int x,int y)
{
    if((x>=0&&x<n) && (y>=0&&y<m)) return true;
    return false;
}

bool check(int x,int y,int c)
{
    if(inside(x+1,y)) if(mp[x+1][y]==c) return false;
    if(inside(x-1,y)) if(mp[x-1][y]==c) return false;
    if(inside(x,y+1)) if(mp[x][y+1]==c) return false;
    if(inside(x,y-1)) if(mp[x][y-1]==c) return false;
    return true;
}

bool vis[30];

bool dfs(int x,int y,int cnt)
{
	if(flag==true) return true;
	if(x==n+1||cnt==0)
	{
		flag=true;
		return true;
	}
	for(int i=1;i<=k;i++)
	{
		if(ccc[i]>(cnt+1)/2) return false;
	}
	for(int i=0;i<n*m;i++)
	{
		if(vis[i]==true) continue;
		if(check(x,y,color[i])==true)
		{
			vis[i]=true;
			mp[x][y]=color[i];
			ccc[color[i]]--;
			int ny=y+1,nx=x;
			if(ny>=m) {ny=0; nx++;}
			dfs(nx,ny,cnt-1);
			if(flag==true) return true;
			ccc[color[i]]++;
			mp[x][y]=0;
			vis[i]=false;
		}
	}
	return false;
}

int main()
{
    int T_T,cas=1;
    scanf("%d",&T_T);
    while(T_T--)
    {
        memset(mp,0,sizeof(mp));
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0;i<k;i++)
        {
            int x;
           	scanf("%d",&x);
            c[i].num=x;
            c[i].color=i+1;
            ccc[i+1]=x;
        }
        sort(c,c+k,cmp);
        printf("Case #%d:\n",cas++);
        if(c[k-1].num>(((n+1)/2)*((m+1)/2)+(n/2)*(m/2)))
        {
            puts("NO"); continue;
        }
        int pos=0;
        for(int i=0;i<k;i++)
        {
            int t=c[i].num;
            int cc=c[i].color;
            while(t--)
            {
                color[pos++]=cc;
            }
        }
        flag=false;
        memset(vis,false,sizeof(vis));
        dfs(0,0,n*m);
        if(flag)
        {
            puts("YES");
            for(int i=0;i<n;i++)
                for(int j=0;j<m;j++)
                    printf("%d%c",mp[i][j],(j==m-1)?'\n':' ');
        }
        else puts("NO");
    }
    return 0;
}



HDOJ 5113 Black And White DFS+剪枝

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://blog.csdn.net/ck_boss/article/details/41632143

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!