码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1224_Free DIY Tour【DP】【回溯】

时间:2014-12-01 12:55:03      阅读:304      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   ar   os   sp   java   for   

Free DIY Tour


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4336    Accepted Submission(s): 1391

Problem Description
Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It‘s a good chance to relax themselves. To most of them, it‘s the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company‘s statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number. 

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 and N+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?
 
Input
The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.
 
Output
For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit. 

Output a blank line between two cases.

Sample Input
2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4
 
Sample Output
CASE 1#
points : 90
circuit : 1->3->1

CASE 2#
points : 90
circuit : 1->2->1

Author

JGShining(极光炫影)


题目大意:进行一场DIY的旅行,总共有N座城市,每座城市有一个

有趣值,但是城市之间不一定有直接通往的航班。 给你城市间航班

情况。每次从第一个城市出发,最后回到第一个城市,形成一个环

路。问使得有趣值最大的最佳环路和其有趣值是什么。

思路:设dp[i]为从城市1到第i个城市获得的最大有趣值和,更新dp[i]

的时候,用pre[i]记录当前节点的前驱,最后向前回溯并记录路径。

然后输出路径。


#include<stdio.h>
#include<string.h>

int point[110],map[110][110],pre[110],dp[110],ans[110];
int main()
{
    int T,N,M,kase = 1;
    scanf("%d",&T);
    while(T--)
    {
        memset(point,0,sizeof(point));
        memset(map,0,sizeof(map));
        memset(pre,0,sizeof(pre));
        memset(dp,0,sizeof(dp));
        scanf("%d",&N);
        for(int i = 1; i <= N; i++)
            scanf("%d",&point[i]);
        point[N+1] = 0;
        scanf("%d",&M);
        int x,y;
        for(int i = 0; i < M; i++)
        {
            scanf("%d%d",&x,&y);
            map[x][y] = 1;
        }

        pre[1] = -1;
        for(int i = 1; i <= N+1; i++)
        {
            for(int j = 1; j < i; j++)
            {
                if(map[j][i] && dp[i] < dp[j] + point[i])
                {
                    dp[i] = dp[j] + point[i];
                    pre[i] = j;
                }
            }
        }

        printf("CASE %d#\n",kase++);
        printf("points : %d\n",dp[N+1]);
        printf("circuit : ");
        int i = N+1;
        int j = 0;
        while(pre[i]!=-1)
        {
            ans[j++] = pre[i];
            i = pre[i];
        }
        for(int i = j-1; i >= 0; i--)
            printf("%d->",ans[i]);
        printf("1\n");
        if(T!=0)
            printf("\n");
    }
    return 0;
}



HDU1224_Free DIY Tour【DP】【回溯】

标签:des   style   blog   io   ar   os   sp   java   for   

原文地址:http://blog.csdn.net/lianai911/article/details/41645809

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!