码迷,mamicode.com
首页 > 其他好文 > 详细

1089. Insert or Merge (25)

时间:2014-12-01 14:15:01      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:style   blog   http   io   ar   color   os   sp   for   

1089. Insert or Merge (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:
Merge Sort
1 2 3 8 4 5 7 9 0 6

提交代码

bubuko.com,布布扣
/*
1.题目不会出现 第二组序列就是排好的序列的情况(这种情况无法判断并且没有下一序列)
2.插入是一个个往前放
3.归并是先两个两个排,再四个四个排,所有数归并以后算一个序列
4.注意下一序列和输入的第二组序列不能相同
*/
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int n,a[110],aa[110],b[110],sorted[110];
void output(int *x)
{
    printf("%d",x[0]);
    for(int i=1;i<n;i++)printf(" %d",x[i]);
    puts("");
}
bool isequal(int *x,int *y)
{
    for(int i=0;i<n;i++)
        if(x[i]!=y[i])return false;
    return true;
}
bool checkinsert()
{
    int flag=0;
    for(int i=2;i<=n;i++){
        if(flag&&!isequal(aa,b)){
                puts("Insertion Sort");
                output(aa);
                return true;
        }
        sort(aa,aa+i);
       // printf("**");output(aa);
        if(isequal(aa,b))flag=1;
    }
    return false;
}
void checkmerge()
{
    int flag=0;
    for(int i=2;i<=n;i*=2)
    {
        int j;
        for(j=0;j+i<=n;j+=i)
        {
            if(isequal(a,b))flag=1;
            sort(a+j,a+j+i);
        }
        sort(a+j,a+n);
        if(isequal(a,b))flag=1;
        if(flag&&!isequal(a,b)){
                puts("Merge Sort");
                output(a);
                return;
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            aa[i]=a[i];
            sorted[i]=a[i];
        }
        sort(sorted,sorted+n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&b[i]);
        }
        if(!checkinsert())
            checkmerge();

    }
    return 0;
}
PAT1089

 

1089. Insert or Merge (25)

标签:style   blog   http   io   ar   color   os   sp   for   

原文地址:http://www.cnblogs.com/kylehz/p/4134915.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!