码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2492 A Bug's Life 【并查集】

时间:2014-12-01 22:27:04      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:poj2492

A Bug‘s Life
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 29011   Accepted: 9451

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs‘ sexual behavior, or "Suspicious bugs found!" if Professor Hopper‘s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany

题目大意:找同性恋。。。开始把题意解释给磊哥时,我想着这题可能是判定二分图,然后捉摸着用二分染色,磊哥说是并查集,我觉得并查集也行,但是直到比赛结束我们两种方法都没实现出来。。。-_-!

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
typedef long long LL;

#define maxn 4010
#define maxm 1000010

int pre[maxn];

int ufind(int k) {
    int a = k, b;
    while(pre[k] != -1) k = pre[k];
    while(a != k) {
        b = pre[a];
        pre[a] = k;
        a = b;
    }
    return k;
}

bool same(int a, int b) {
    return ufind(a) == ufind(b);
}

void unite(int a, int b) {
    a = ufind(a);
    b = ufind(b);
    if(a != b) pre[a] = b;
}

int main() {
    // freopen("stdin.txt", "r", stdin);
    int T, cas, i, j, N, M, a, b, ok;
    scanf("%d", &T);
    for(cas = 1; cas <= T; ++cas) {
        printf("Scenario #%d:\n", cas);
        scanf("%d%d", &N, &M);
        memset(pre, -1, sizeof(int) * (2 * N + 1));
        ok = 0;
        while(M--) {
            scanf("%d%d", &a, &b);
            if(ok) continue;
            if(same(a, b))
                ok = 1;
            else {
                unite(a, b + N);
                unite(a + N, b);
            }
        }
        printf(ok ? "Suspicious bugs found!" : "No suspicious bugs found!");
        printf("\n\n");
    }
    return 0;
}


POJ2492 A Bug's Life 【并查集】

标签:poj2492

原文地址:http://blog.csdn.net/chang_mu/article/details/41648151

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!