码迷,mamicode.com
首页 > 其他好文 > 详细

Brackets sequence

时间:2014-12-01 22:30:29      阅读:247      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   ar   color   os   sp   for   on   

Description:

Let us define a regular brackets sequence in the following way:
1.Empty sequence is a regular sequence.
2.If S is a regular sequence, then (S) and [S] are both regular sequences.
3.If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters ‘(‘, ‘)‘, ‘[‘, and ‘]‘ is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1a2...an is called a subsequence of the string b1b2...bm, if there exist such indices 1 ≤ i1 < i2 < ... < in ≤ m, that aj=bij for all 1 ≤ j ≤ n.

Input
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.


The input file contains at most 100 brackets (characters ‘(‘, ‘)‘, ‘[‘ and ‘]‘) that are situated on a single line without any other characters among them.

Output
For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.


Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input
1

([(]

Sample Output
()[()]


# include <cstdio>
# include <cstring>
# include <algorithm>
# include <iostream>
using namespace std;

int d[105][105],len;     //数组 d 的含义,从第 i 个字符到第 j 字符需要匹配多少括号;
char s[105];

bool match(char a , char b)    //判断是否括号匹配;
{
    if(a=='('&&b==')'|| a=='['&&b==']')    return true;
    else    return false;
}

void dp( )
{
    int i,j,k;
    for(i=0;i<len;i++)    //数据重置;
    {
        d[i+1][i]=0;
        d[i][i]=1;
    }
    for(i=len-2;i>=0;i--)    //从倒数第二个字符串开始;
    {
        for(j=i+1;j<len;j++)
        {
            d[i][j] = len;
            //如果最外层的括号是匹配的,那么把下标往里移动;
            if( match (s[i],s[j]) )  d[i][j] = min (d[i][j],d[i+1][j-1]);
            //继续寻找最优解;
            for(k=i;k<j;k++)
                d[i][j] = min ( d[i][j],d[i][k] + d[k+1][j] );
        }
    }
}

void print(int i,int j)    //其实就是倒推的过程;
{
    if( i>j )  return ;
    if( i==j )
    {
        if( s[i]=='('||s[i]==')' )    printf("()");
        else    printf("[]");
        return ;
    }
    int ans = d [i] [j];
    if( match(s[i],s[j]) && ans== d[i+1][j-1] )    //判断最外层的两个括号是不是匹配的,再看最优值是不是dp [i-1] [j+1];
    {
        printf("%c",s[i]);    print(i+1,j-1);    printf("%c",s[j]);    return ;
    }
    for( int k =i; k<j ;k++)
    {
        if( ans == d[i][k]+d[k+1][j] )
        {
            print( i, k);    print( k+1, j);    return ;
        }
    }
}

void readline(char *s)
{
    fgets(s,105,stdin);
}

int main()
{
    int n;
    readline(s);
    sscanf(s, "%d", &n);
    readline(s);
    while(n--)
    {
        readline(s);
        len=strlen(s)-1;
        memset(d,-1,sizeof(d));
        dp();
        print(0,len-1);
        cout<<"\n";
        if(n)    cout<<"\n";
        readline(s);
    }
    return 0;
}


Brackets sequence

标签:des   style   io   ar   color   os   sp   for   on   

原文地址:http://blog.csdn.net/rechard_chen/article/details/41653851

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!