码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 10791 - Minimum Sum LCM (数论相关!)

时间:2014-12-01 22:36:41      阅读:310      评论:0      收藏:0      [点我收藏+]

标签:uva   algorithm   acm   icpc   basic   

题目链接:Minimum Sum LCM


UVA - 10791

Time Limit:3000MS   Memory Limit:Unknown   64bit IO Format:%lld & %llu

Status

Description

bubuko.com,布布扣


  Minimum Sum LCM 

bubuko.com,布布扣

LCM (Least Common Multiple) of a set of integers is defined as the minimum number, which is a multiple of all integers of that set. It is interesting to note that any positive integer can be expressed as the LCM of a set of positive integers. For example 12 can be expressed as the LCM of 1, 12 or 12, 12 or 3, 4 or 4, 6 or 1, 2, 3, 4 etc.

In this problem, you will be given a positive integer N. You have to find out a set of at least two positive integers whose LCM is N. As infinite such sequences are possible, you have to pick the sequence whose summation of elements is minimum. We will be quite happy if you just print the summation of the elements of this set. So, for N = 12, you should print 4+3 = 7 as LCM of 4 and 3 is 12 and 7 is the minimum possible summation.

Input 

The input file contains at most 100 test cases. Each test case consists of a positive integer N ( 1bubuko.com,布布扣Nbubuko.com,布布扣231 - 1).

Input is terminated by a case where N = 0. This case should not be processed. There can be at most 100 test cases.

Output 

Output of each test case should consist of a line starting with `Case #: ‘ where # is the test case number. It should be followed by the summation as specified in the problem statement. Look at the output for sample input for details.

Sample Input 

 
12
10
5
0

Sample Output 

 
Case 1: 7
Case 2: 7
Case 3: 6



Problem setter: Md. Kamruzzaman
Special Thanks: Shahriar Manzoor

Miguel Revilla 2004-12-10

Source

Root :: AOAPC II: Beginning Algorithm Contests (Second Edition) (Rujia Liu) :: Chapter 10. Maths :: Examples
Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 6. Mathematical Concepts and Methods
Root :: AOAPC I: Beginning Algorithm Contests -- Training Guide (Rujia Liu) :: Chapter 2. Mathematics :: Basic Problems
Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Mathematics :: Number Theory :: Working with Prime Factors

Root :: Prominent Problemsetters :: Md. Kamruzzaman (KZaman)
Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Mathematics :: Number Theory :: Working with Prime Factors


思路:分解质因子,将最小公倍数分解质因子,最小的ans便为各个质因子的相应次方数之和。

此题难点较多:

1、当N = 1时,应输出2;

2、当N是素数的时候,输出N+1;

3、当只有单质因子时,sum=质因子相应次方+1;

4、当N=2147483647时,它是一个素数,此时输出2147483648,但是它超过int范围,应考虑用long long。



AC代码:

/*************************************************************************
	> File Name: e.cpp
	> Author: zzuspy
	> Mail: zzuspy@qq.com 
	> Created Time: 2014年12月01日 星期一 19时18分33秒
 ************************************************************************/



#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <stack>
#include <queue>
#define LL long long
#define max3(a,b,c) max(a,max(b,c))
#define min3(a,b,c) min(a,min(b,c))
using namespace std;

int main()
{
	int n, cas = 1;
	while(scanf("%d", &n), n)
	{
		int m = (int)sqrt((double)n+0.5);
		int t = n, num = 0;
		LL ans = 0;
		for(int i=2; i<=m; i++)   //分解这个数
			if(t%i == 0)
			{
				num++;   //记录质因子的个数
				int tmp = 1;
				while(t%i==0)
				{
					tmp*=i;
					t/=i;
				}
				ans+=tmp;
			}
		if(n==t)  //本身为素数时
			ans = (LL)n + 1;   //必须要加个(LL)
		else if(num == 1||t!=1)  // 单质因子或是剩下一个大于sqrt(n)的质因子的情况  
			ans += t;	// 单质因子情况下t为1,剩余一个大于sqrt(n)质因子时t为剩余质因子  		
		printf("Case %d: %lld\n", cas++, ans);
	}
	return 0;
}






UVA - 10791 - Minimum Sum LCM (数论相关!)

标签:uva   algorithm   acm   icpc   basic   

原文地址:http://blog.csdn.net/u014355480/article/details/41651549

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!