码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1011 Sticks 【剪枝】

时间:2014-12-02 00:11:43      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:poj1011

Sticks
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 122771   Accepted: 28441

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

Source

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

int Len[66], tarLen, tarCnt, N, sum, cnt;
bool vis[66];

bool DFS(int k, int leftLen) {
	int i;
	if(leftLen == 0) {
		if(++cnt == tarCnt) return true;
		for(i = 0; i < N; ++i)
			if(!vis[i]) {
				vis[i] = 1;
				if(DFS(i + 1, tarLen - Len[i]))
					return true;
				else {
					vis[i] = 0;
					--cnt;
					return false;
				}
			}
	}
	for(i = k; i < N; ++i) {
		if(!vis[i] && Len[i] <= leftLen) {
			if(Len[i] == Len[i-1] && !vis[i-1])
				continue;
			vis[i] = 1;
			if(DFS(i + 1, leftLen - Len[i]))
				return true;
			vis[i] = 0;
		}
	}
	return false;
}

int main() {
	int i, j;
	while(scanf("%d", &N), N) {
		for(i = sum = 0; i < N; ++i) {
			scanf("%d", &Len[i]);
			sum += Len[i];
		}
		sort(Len, Len + N, greater<int>());
		for(tarLen = Len[0]; tarLen < sum; ++tarLen) {
			if(sum % tarLen) continue;
			tarCnt = sum / tarLen;
			memset(vis, 0, sizeof(vis));
			vis[0] = 1; cnt = 0;
			if(DFS(1, tarLen - Len[0])) break;
		}
		printf("%d\n", tarLen);
	}
	return 0;
}



POJ1011 Sticks 【剪枝】

标签:poj1011

原文地址:http://blog.csdn.net/chang_mu/article/details/41657703

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!