码迷,mamicode.com
首页 > 其他好文 > 详细

求和求到手软

时间:2014-12-02 11:54:00      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:style   blog   io   ar   color   os   sp   for   on   

描述

LN想要知道大家的小学数学好不好。

现在他想让你求出几个数的和。

你能搞定么?

输入
多组测试数据 
一组测试数据一行。
输出
一个数sum,表示结果。(保证在 int 范围内)
样例输入
2 3 5
5 6 7 8
1 2 3 4 5 6 7 8 9 10
样例输出
10
26
55
代码如下
这道题考察的点很清晰,就是对输入数据的处理。
如果每组测试数据的 n 个数得到后,求和就非常简单,而且保证在int范围内。

如果用普通的整数输入的话,每组测试数据之间没有明显的区分度。所以我们应该有个直觉是转化成字符串读入,而后进行求和。
#include<stdio.h>
#include<string.h>
int main()
{
	char a[100000];
	int i,sum,t;
	while(gets(a))
	{
		sum=0;t=0;
		for(i=0;a[i];i++)
		{
			if(a[i]==' ')
			{
				t+=sum;
				sum=0;
			}
			else
				sum=sum*10+(a[i]-'0');
		}
		t+=sum;
		printf("%d\n",t);
	}

	return 0;
}



求和求到手软

标签:style   blog   io   ar   color   os   sp   for   on   

原文地址:http://blog.csdn.net/phytn/article/details/41675579

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!