标签:hdu 1003 max sum
Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 153057 Accepted Submission(s): 35699
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
Author
Ignatius.L
Recommend
We have carefully selected several similar problems for you:
1176 1069 1058 1159 1257
AC CODE:
#include<stdio.h>
main()
{
int n, i, a[100002], b, j, s, m, k;
long max, sum;
while ( scanf ( "%d", &n ) != EOF )
{
for ( j = 1; j <= n; j++ )
{
scanf ( "%d", &m );
for ( i = 0; i < m; i++ )
scanf ( "%d", &a[i] );
sum = 0;
b = 1;
max = -1001;
for ( i = 0; i < m; i++ )
{
sum += a[i];
if ( sum > max )
{
max = sum;
k = b;
s = i + 1;
}
if ( sum < 0 )
{
sum = 0;
b = i + 2;
}
}
if ( j != n )
printf ( "Case %d:\n%ld %d %d\n\n", j, max, k, s );
else
printf ( "Case %d:\n%ld %d %d\n", j, max, k, s );
}
}
}
hdu 1003 Max Sum
标签:hdu 1003 max sum
原文地址:http://blog.csdn.net/acm_baihuzi/article/details/41677223