码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1001 sum problem

时间:2014-12-02 13:34:21      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:hdu 1001   sum problem   

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 302207    Accepted Submission(s): 75492


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input
1 100
 

Sample Output
1 5050
 

Author
DOOM III
 

Recommend
We have carefully selected several similar problems for you:  1013 1010 1006 1020 1007 
 

#include<stdio.h>
int main()
{
    int n,i;
    double sum;
    while(scanf("%ld",&n)!=EOF)
    {   sum=0;
        for(i=1;i<=n;i++)
        sum+=i;
        printf("%.0lf\n\n",sum);
    }
    return 0;
}


 


hdu 1001 sum problem

标签:hdu 1001   sum problem   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/41677145

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!