码迷,mamicode.com
首页 > 其他好文 > 详细

hdu3016——Man Down

时间:2014-12-02 22:35:33      阅读:219      评论:0      收藏:0      [点我收藏+]

标签:dp   线段树   

Man Down

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1740    Accepted Submission(s): 626


Problem Description
The Game “Man Down 100 floors” is an famous and interesting game.You can enjoy the game from
http://hi.baidu.com/abcdxyzk/blog/item/16398781b4f2a5d1bd3e1eed.html
bubuko.com,布布扣

We take a simplified version of this game. We have only two kinds of planks. One kind of the planks contains food and the other one contains nails. And if the man falls on the plank which contains food his energy will increase but if he falls on the plank which contains nails his energy will decrease. The man can only fall down vertically .We assume that the energy he can increase is unlimited and no borders exist on the left and the right.

First the man has total energy 100 and stands on the topmost plank of all. Then he can choose to go left or right to fall down. If he falls down from the position (Xi,Yi),he will fall onto the nearest plank which satisfies (xl <= xi <= xr)(xl is the leftmost position of the plank and xr is the rightmost).If no planks satisfies that, the man will fall onto the floor and he finishes his mission. But if the man’s energy is below or equal to 0 , he will die and the game is Over.

Now give you the height and position of all planks. And ask you whether the man can falls onto the floor successfully. If he can, try to calculate the maximum energy he can own when he is on the floor.(Assuming that the floor is infinite and its height is 0,and all the planks are located at different height).
 

Input
There are multiple test cases.

For each test case, The first line contains one integer N (2 <= N <= 100,000) representing the number of planks.

Then following N lines representing N planks, each line contain 4 integers (h,xl,xr,value)(h > 0, 0 < xl < xr < 100,000, -1000 <= value <= 1000), h represents the plank’s height, xl is the leftmost position of the plank and xr is the rightmost position. Value represents the energy the man will increase by( if value > 0) or decrease by( if value < 0) when he falls onto this plank.
 

Output
If the man can falls onto the floor successfully just output the maximum energy he can own when he is on the floor. But if the man can not fall down onto the floor anyway ,just output “-1”(not including the quote)
 

Sample Input
4 10 5 10 10 5 3 6 -100 4 7 11 20 2 2 1000 10
 

Sample Output
140
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:  1542 1828 1540 2871 1698 
 

一开始的写法超时了,然后用线段树优化了下, 转移的复杂度降到了O(logn),总复杂度是O(n * logn)

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#pragma comment(linker, "/STACK:102400000, 102400000")

using namespace std;

const int N = 100010;
const int inf = 0x3f3f3f3f;

int dp[N][2];
int n;
struct node
{
	int l, r;
	int h;
	int w;
}blank[N];

struct node2
{
	int l, r;
	int h;
	int col;
}tree[N << 2];

int cmp(node a, node b)
{
	return a.h > b.h;
}

void build(int p, int l, int r)
{
	tree[p].l = l;
	tree[p].r = r;
	tree[p].col = -1;
	if (l == r)
	{
		return;
	}
	int mid = (l + r) >> 1;
	build(p << 1, l, mid);
	build(p << 1 | 1, mid + 1, r);
}

void update(int p, int l, int r, int val)
{
	if (l <= tree[p].l && tree[p].r <= r)
	{
		tree[p].col = val;
		return;
	}
	if (tree[p].col != -1)
	{
		tree[p << 1].col = tree[p].col;
		tree[p << 1 | 1].col = tree[p].col;
		tree[p].col = -1;
	}
	int mid = (tree[p].l + tree[p].r) >> 1;
	if (r <= mid)
	{
		update(p << 1, l, r, val);
	}
	else if (l > mid)
	{
		update(p << 1 | 1, l, r, val);
	}
	else
	{
		update(p << 1, l, mid, val);
		update(p << 1 | 1, mid + 1, r, val);
	}
}

int query(int p, int pos)
{
	if (tree[p].l == tree[p].r)
	{
		return tree[p].col;
	}
	if (tree[p].col != -1)
	{
		tree[p << 1].col = tree[p].col;
		tree[p << 1 | 1].col = tree[p].col;
		tree[p].col = -1;
	}
	int mid = (tree[p].l + tree[p].r) >> 1;
	if (pos <= mid)
	{
		return query(p << 1, pos);
	}
	else
	{
		return query(p << 1 | 1, pos);
	}
}

int main()
{
	while(~scanf("%d", &n))
	{
		memset (dp, -1, sizeof(dp));
		int left = inf, right = -inf;
		for (int i = 0; i < n; ++i)
		{
			scanf("%d%d%d%d", &blank[i].h, &blank[i].l, &blank[i].r, &blank[i].w);
			left = min(left, blank[i].l);
			right = max(right, blank[i].r);
		}
		// printf("%d %d\n", left, right);
		build(1, left, right);
		sort (blank, blank + n, cmp);
		for (int i = n - 1; i >= 0; --i)
		{
			int j = query(1, blank[i].l);
			if (j != -1)
			{
				dp[i][0] = max(dp[j][0], dp[j][1]) + blank[j].w;
			}
			else
			{
				dp[i][0] = 0;
			}
			j = query(1, blank[i].r);
			if (j != -1)
			{
				dp[i][1] = max(dp[j][0], dp[j][1]) + blank[j].w;
			}
			else
			{
				dp[i][1] = 0;
			}
			update(1, blank[i].l, blank[i].r, i);
		}
		int ans = max(dp[0][0], dp[0][1]) + 100 + blank[0].w;
		if (ans <= 0)
		{
			ans = -1;
		}
		printf("%d\n", ans);
	}
	return 0;
}


hdu3016——Man Down

标签:dp   线段树   

原文地址:http://blog.csdn.net/guard_mine/article/details/41684695

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!