码迷,mamicode.com
首页 > 其他好文 > 详细

Number Sequence(杭电1711)(KMP)

时间:2014-12-03 00:29:41      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11925    Accepted Submission(s): 5440


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
6 -1
 

Source
/*KMP算法关键是求next函数,第一道KMP题,最基础的题,
借鉴普浩冉的代码和讲解,还算有点理解吧= = 
*/
#include<stdio.h>
int a[1000002];
int s[10002],next[10002];
int m,n;
void get_next(int *s)
{
	int i=0,j=-1;
	next[0]=-1;
	while(i<m-1){
		if(j==-1||s[i]==s[j])
		{
			i++;
			j++;
			next[i]=j;
		}
		else
		j=next[j];
	}
}
int kmp(int *a,int *s)
{
	int i=0,j=0;
	get_next(s);
	while(i<=n-1)
	{
		if(j==-1||a[i]==s[j])
		{
			i++;
			j++;
		}
		else
		    j=next[j];
		if(j==m)
		    return i-m+1;
	}
	return -1;
}
int main()
{
	int test,i;
	scanf("%d",&test);
	while(test--)
	{
		scanf("%d %d",&n,&m);
		for(i=0;i<n;i++)
		    scanf("%d",&a[i]);
		for(i=0;i<m;i++)
		    scanf("%d",&s[i]);
		printf("%d\n",kmp(a,s));
	}
	return 0;
}

Number Sequence(杭电1711)(KMP)

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://blog.csdn.net/hdd871532887/article/details/41687171

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!