标签:poj zoj c++ 算法 编程
Blocks
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 7350 |
|
Accepted: 3543 |
Description
Donald wishes to send a gift to his new nephew, Fooey. Donald is a bit of a traditionalist, so he has chosen to send a set of N classic baby blocks. Each block is a cube, 1 inch by 1 inch by 1 inch. Donald wants to stack the blocks together into a rectangular
solid and wrap them all up in brown paper for shipping. How much brown paper does Donald need?
Input
The first line of input contains C, the number of test cases. For each case there is an additional line containing N, the number of blocks to be shipped. N does not exceed 1000.
Output
Your program should produce one line of output per case, giving the minimal area of paper (in square inches) needed to wrap the blocks when they are stacked together.
Sample Input
5
9
10
26
27
100
Sample Output
30
34
82
54
130
题意:已知一个立方体的体积,求这个立方体的最小表面积;
题解:暴力枚举x和y;
#include <iostream>
using namespace std;
int main(){
int n,t;
cin>>t;
while (cin>>n){
int min=0xffffff;
for (int x=1;x<=n;x++){
if (n%x!=0)
continue;
for (int y=1;y<=n;y++){
if (n%y!=0||n%(x*y)!=0)
continue;
int z=n/(x*y);
int s=2*(x*y+x*z+y*z);
if (min>s)
min=s;
}
}
cout<<min<<endl;
}
return 0;
}
poj 2363 Blocks
标签:poj zoj c++ 算法 编程
原文地址:http://blog.csdn.net/codeforcer/article/details/41692783