码迷,mamicode.com
首页 > 其他好文 > 详细

剑指offer系列-用两个栈实现队列

时间:2014-12-04 20:03:58      阅读:157      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

oj地址

题目1512:用两个栈实现队列

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:2360

解决:804

题目描述:

用两个栈来实现一个队列,完成队列的Push和Pop操作。
队列中的元素为int类型。

输入:

每个输入文件包含一个测试样例。
对于每个测试样例,第一行输入一个n(1<=n<=100000),代表队列操作的个数。
接下来的n行,每行输入一个队列操作:
1. PUSH X 向队列中push一个整数x(x>=0)
2. POP 从队列中pop一个数。

输出:

对应每个测试案例,打印所有pop操作中从队列pop中的数字。如果执行pop操作时,队列为空,则打印-1。

样例输入:
3
PUSH 10
POP
POP
样例输出:
10
-1
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stack>
using namespace std;
template <typename T> class CQueue{
    public:
        //CQueue(void);
        //~CQueue(void);
        void appendTail(const T& node);
        T deleteHead();
    private:
        stack<T> stack1;
        stack<T> stack2;

};
template <typename T> void CQueue<T>::appendTail(const T& node){
    stack1.push(node);
}
template <typename T> T CQueue<T>::deleteHead(){
    if(stack2.size()<=0){
        while(stack1.size()>0){
            T& data = stack1.top();
            stack1.pop();
            stack2.push(data);
        }
    }
    if(stack2.size()==0){
        throw "error";
    }
    T head = stack2.top();
    stack2.pop();
    return head;
}
int main(){
    int n;
    char ch[10];
    int num;
    CQueue<int> cqueue;
    scanf("%d",&n);
    while(n--){
        scanf("%s",ch);
        if(strcmp("PUSH",ch)==0){
            scanf("%d",&num);
            cqueue.appendTail(num);
        }else{
            try{
                printf("%d\n",cqueue.deleteHead());
            }catch(const char * str){
                printf("-1\n");
            }
        }
    }
    return 0;
}



剑指offer系列-用两个栈实现队列

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://blog.csdn.net/hackcoder/article/details/41727951

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!