码迷,mamicode.com
首页 > 其他好文 > 详细

FZU Problem 2102 Solve equation (数学啊 )

时间:2014-12-04 23:19:15      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:fzu   数学   

题目链接:http://acm.fzu.edu.cn/problem.php?pid=2102


Problem Description

You are given two positive integers A and B in Base C. For the equation:

A=k*B+d

We know there always existing many non-negative pairs (k, d) that satisfy the equation above. Now in this problem, we want to maximize k.

For example, A="123" and B="100", C=10. So both A and B are in Base 10. Then we have:

(1) A=0*B+123

(2) A=1*B+23

As we want to maximize k, we finally get one solution: (1, 23)

The range of C is between 2 and 16, and we use ‘a‘, ‘b‘, ‘c‘, ‘d‘, ‘e‘, ‘f‘ to represent 10, 11, 12, 13, 14, 15, respectively.

bubuko.com,布布扣 Input

The first line of the input contains an integer T (T≤10), indicating the number of test cases.

Then T cases, for any case, only 3 positive integers A, B and C (2≤C≤16) in a single line. You can assume that in Base 10, both A and B is less than 2^31.

bubuko.com,布布扣 Output

For each test case, output the solution “(k,d)” to the equation in Base 10.

bubuko.com,布布扣 Sample Input

32bc 33f 16123 100 101 1 2

bubuko.com,布布扣 Sample Output

(0,700)(1,23)(1,0)

bubuko.com,布布扣 Source

“高教社杯”第三届福建省大学生程序设计竞赛

题意:

给出 A 和 B 求满足 A = k * B + d,的最大的K;

c表示A, 和B是几进制!

代码如下:

#include <cstdio>
#include <cstring>
int main()
{
    int t;
    int cas = 0;
    int c;
    char a[47], b[47];
    scanf("%d",&t);
    while(t--)
    {
        int t1 = 0, t2 = 0;
        scanf("%s%s%d",a,b,&c);
        int len1 = strlen(a);
        int len2 = strlen(b);
        for(int i = 0; i < len1; i++)
        {
            t1 *= c;
            if(a[i]<='9' && a[i]>='0')
                t1+=a[i]-'0';
            else
                t1+=a[i]-'a'+10;
        }

        for(int i = 0; i < len2; i++)
        {
            t2 *= c;
            if(b[i]<='9' && b[i]>='0')
                t2+=b[i]-'0';
            else
                t2+=b[i]-'a'+10;
        }
        printf("(%d,%d)\n",t1/t2,t1%t2);
    }
    return 0;
}


FZU Problem 2102 Solve equation (数学啊 )

标签:fzu   数学   

原文地址:http://blog.csdn.net/u012860063/article/details/41731533

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!