码迷,mamicode.com
首页 > 其他好文 > 详细

UVA Master-Mind Hints()

时间:2014-12-05 09:18:14      阅读:280      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   ar   color   os   使用   sp   

Master-Mind Hints
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the length N that a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code bubuko.com,布布扣 and a guess bubuko.com,布布扣 , and are to determine the hint. A hint consists of a pair of numbers determined as follows.

match is a pair (i,j), bubuko.com,布布扣 and bubuko.com,布布扣 , such that bubuko.com,布布扣 . Match (i,j) is called strong when i = j, and is called weak otherwise. Two matches (i,j) and (p,q) are called independent when i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent.

Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.

 

Input

The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single zero (when a value for N would normally be specified). The maximum value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.

Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0

Sample Output

Game 1:
    (1,1)
    (2,0)
    (1,2)
    (1,2)
    (4,0)
Game 2:
    (2,4)
    (3,2)
    (5,0)
    (7,0)


       题意:甲乙两个人玩游戏猜密码,首先输入一个数n,代表密码的个数,第二行是第一个人甲设定的密码a,剩下的是第二个人乙猜的密码b,当输入的数据为n个0时代表输入结束,对于乙猜的数据中如果a[i] == b[i]时,给出一个A,当i!=j,但是a[i] == b[j]时给出一个B,A的优先级大于B,而且题目要求b[j]的数据只能使用一次。很水的一道题...,看懂题意就好了。

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

struct node
{
    int x,y;
}q[100010];
int a[10];
int b[100010];
int c[100001];
int aa[10];

int main()
{
    int n;
    int e = 0;
    while(scanf("%d",&n)!=EOF)
    {
        if(n == 0)
        {
            break;
        }
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
        {
            scanf("%d",&b[i]);
            a[b[i]]++;
        }
        int flag = 0;
        int k = 0;
        while(flag!=1)
        {
            memset(aa,0,sizeof(aa));
            for(int i=0;i<=10;i++)
            {
                aa[i] = a[i];
            }
            int count1 = 0;
            int count2 = 0;
            int tt = 0;
            for(int i=0;i<n;i++)
            {
                scanf("%d",&c[i]);
                if(c[i] == 0)
                {
                    tt++;
                    if(tt == n)
                    {
                        flag = 1;
                        break;
                    }
                }
                if(b[i] == c[i])
                {
                    count1++;
                    aa[c[i]]--;
                    c[i] = 10;
                }
            }
            for(int i=0;i<n;i++)
            {
                if(aa[c[i]] >=1)
                {
                    count2++;
                    aa[c[i]]--;
                }
            }
            q[k].x = count1;
            q[k].y = count2;
            k++;
        }
        printf("Game %d:\n",++e);
        for(int i=0;i<k-1;i++)
        {
            printf("    (%d,%d)\n",q[i].x,q[i].y);
        }
    }
    return 0;
}


UVA Master-Mind Hints()

标签:des   style   http   io   ar   color   os   使用   sp   

原文地址:http://blog.csdn.net/yeguxin/article/details/41737225

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!