码迷,mamicode.com
首页 > 其他好文 > 详细

UVA10474_Where is the Marble?【sort】【lower_bound】

时间:2014-12-05 21:27:06      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   ar   os   sp   for   on   

  Where is the Marble? 

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum points wins. Today it‘s your chance to play as Raju. Being the smart kid, you‘d be taking the favor of a computer. But don‘t underestimate Meena, she had written a program to keep track how much time you‘re taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.


Input 

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative.

Input is terminated by a test case where N = 0 and Q = 0.

Output 

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below:

`x found at y‘, if the first marble with number x was found at position y. Positions are numbered 1, 2,..., N.
`x not found‘, if the marble with number x is not present.
Look at the output for sample input for details.

Sample Input 
4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3

0 0

Sample Output 

CASE# 1:
5 found at 4
CASE# 2:
2 not found

3 found at 3


题目大意:给你N个大理石,每块大理石上写了一个非负整数,将大理石从小到大

排序,然后回答Q个问题。问整数x是否在大理石上写着。如果有就回答是第几个大

理石上写着x。

思路:用sort排序,用lower_bound得到数组中大于等于x的位置,看该数组下标上

的数是否等于x。


#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 10000;
int a[maxn+10];

int main()
{
    int N,Q,kase = 1;
    while(~scanf("%d%d",&N,&Q) && N)
    {
        printf("CASE# %d:\n",kase++);
        for(int i = 0; i < N; i++)
            scanf("%d",&a[i]);
        sort(a,a+N);
        while(Q--)
        {
            int x;
            scanf("%d",&x);
            int p = lower_bound(a,a+N,x) - a;
            if(a[p] == x)
                printf("%d found at %d\n",x, p+1);
            else
                printf("%d not found\n",x);
        }
    }

    return 0;
}



UVA10474_Where is the Marble?【sort】【lower_bound】

标签:des   style   blog   io   ar   os   sp   for   on   

原文地址:http://blog.csdn.net/lianai911/article/details/41751225

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!