码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1856 More is better (并查集)

时间:2014-12-05 22:44:53      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:hdu   并查集   1856   more is better   

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 15639    Accepted Submission(s): 5761


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang‘s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 

这也是一个并查序的问题,问的是friends最多有多少个,其实就是计算ranks的最大值。

#include<iostream>
#include<stdio.h>
using namespace std;
#define M 10000010
int ranks[M];//一开始还以为空间不够,结果这题给的空间很大
int pre[M];
int _find(int node)
{
    int t=node;
    if(node==pre[node])return node;
    else
        return pre[node]=_find(pre[node]);
}
int _union(int a,int b)
{
    int p=_find(a);
    int q=_find(b);
    if(p!=q)
    {
        if(ranks[p]<ranks[q]){pre[p]=q;
            ranks[q]+=ranks[p];}
            else{
                pre[q]=p;
                ranks[p]+=ranks[q];
            }
    }
}
int main(int argc, char *argv[])
{
    //freopen("1856.in","r",stdin);
    int n;
    int a,b;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<M;++i)
        {
            pre[i]=i;
            ranks[i]=1;
        }
        while(n--)
        {
            scanf("%d %d",&a,&b);
            _union(a , b);
        }
        int max=0;
        for(int i=1;i<M;++i)
        {
            if(ranks[i]>max)max=ranks[i];
        }
        printf("%d\n",max);

    }
    return 0;
}




HDU 1856 More is better (并查集)

标签:hdu   并查集   1856   more is better   

原文地址:http://blog.csdn.net/wdkirchhoff/article/details/41758861

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!