码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3050 Hopscotch 【DFS】

时间:2014-12-06 14:07:12      阅读:180      评论:0      收藏:0      [点我收藏+]

标签:dfs

Hopscotch
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2156   Accepted: 1548

Description

The cows play the child‘s game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS: 
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.
数据太水了,简单深搜

代码:

#include <cstdio>
#include <cstring>

const int dx[] = {0, 0, 1, -1};
const int dy[] = {1, -1, 0, 0};
int ans, num, map[10][10];
bool vis[1000000];

void dfs(int x, int y, int cur, int step){
    if(step == 6){
        if(!vis[cur]){
        vis[cur] = 1;
        ++ans;
        }
        return ;
    }
    int i;
    for(i = 0; i < 4; i ++){
        int nx = x+dx[i]; int ny = y+dy[i];
        if(nx<0||nx>=5||ny<0||ny>=5) continue;
        dfs(nx, ny, cur*10+map[nx][ny], step+1);
    }
}

void sol(){
    ans = 0;
    int i, j;
    for(i = 0; i < 5; i ++){
        for(j = 0; j < 5; j ++){
            //printf("fdjkl");
            dfs(i, j, map[i][j], 1);
        }
    }
}

int main(){
    int i, j;
    for(i = 0; i < 5; i ++)
        for(j = 0; j < 5; j ++)
            scanf("%d", &map[i][j]);

   // printf("dfgjk\n");
    sol();
    printf("%d\n", ans);
    return 0;
}


poj 3050 Hopscotch 【DFS】

标签:dfs

原文地址:http://blog.csdn.net/shengweisong/article/details/41775025

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!