码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2318 TOYS (点与线段位置关系判断)

时间:2014-12-06 14:09:23      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   ar   color   os   sp   for   

TOYS
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10848   Accepted: 5206

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John‘s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
bubuko.com,布布扣 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

题目很简单,判断一下点与线段关系,枚举线段时,可以按区间二分枚举,左右边界。


#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#include<vector>
#include<algorithm>
using namespace std;
#define N 5005
#define ll long long
int n,cnt[N];
struct p
{
    int x,y;
}a,b,c,up[N],down[N];
double cross(p a,p b,p c)
{
    return 1.0*(b.x-a.x)*(c.y-a.y)-1.0*(c.x-a.x)*(b.y-a.y);
}
int judge(p a)
{
    int l=1,r=n,mid;
    while(l<=r)
    {
        mid=(l+r)>>1;
        double s1=cross(a,down[mid-1],up[mid-1]);
        double s2=cross(a,down[mid],up[mid]);
        //printf("%d %.3f %.3f\n",mid,s1,s2);
        if(s1*s2<0)
            return mid;
        if(s2<0)
            l=mid+1;
        else
            r=mid-1;
    }
    return l;
}
int main()
{
    int i,t,m;
    while(scanf("%d",&n),n)
    {
        scanf("%d%d%d%d%d",&m,&b.x,&b.y,&c.x,&c.y);
        up[0].x=down[0].x=b.x;  //box起始点
        up[0].y=up[n+1].y=b.y;
        up[n+1].x=down[n+1].x=c.x; //box终点
        down[0].y=down[n+1].y=c.y;
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&up[i].x,&down[i].x);
            up[i].y=b.y;
            down[i].y=c.y;
        }
        n++;
        memset(cnt,0,sizeof(cnt));
        while(m--)
        {
            scanf("%d%d",&a.x,&a.y);
            t=judge(a);     // 二分判断位置关系
            cnt[t]++;
        }
        for(i=0;i<n;i++)
        {
            printf("%d: %d\n",i,cnt[i+1]);
        }
        puts("");
    }
    return 0;
}







poj 2318 TOYS (点与线段位置关系判断)

标签:des   style   http   io   ar   color   os   sp   for   

原文地址:http://blog.csdn.net/u011721440/article/details/41774839

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!