码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2195 & HDU 1533 Going Home(最小费用最大流)

时间:2014-12-07 23:15:18      阅读:327      评论:0      收藏:0      [点我收藏+]

标签:最小费用最大流   poj   hdu   

题目链接:

POJ:http://poj.org/problem?id=2195

HDU:http://acm.hdu.edu.cn/showproblem.php?pid=1533


Description

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man. 

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a ‘.‘ means an empty space, an ‘H‘ represents a house on that point, and am ‘m‘ indicates there is a little man on that point. 
bubuko.com,布布扣

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of ‘H‘s and ‘m‘s on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2
10
28

Source


题意:

一个N行M列的矩阵,其中“.”代表空地,“H”代表房子,“m”代表人,其中有 n 个房子和 n 个人。

现在要求每个人进入其中的一间房子,且每人每走一步需要支付1美元。

求最小需要花费多少美元能让所有人都进入到房子中(每个人只能进入一间房子,每个房子只能容纳一个人)。

PS:

建立超级源点,分别连接每个m,容量为1,费用0

建立超级汇点,分别把每个H连接到汇点,容量为1,费用为0

再把每个m分别指向H,容量为1,费用为该m到H的横纵坐标之差的绝对值的和,|X1-X2|+|Y1-Y2|;

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
using namespace std;
const int MAXN = 10000;
const int MAXM = 100000;
const int INF = 0x3f3f3f3f;
struct Edge
{
    int to, next, cap, flow, cost;
    int x, y;
} edge[MAXM],HH[MAXN],MM[MAXN];
int head[MAXN],tol;
int pre[MAXN],dis[MAXN];
bool vis[MAXN];
int N, M;
char map[MAXN][MAXN];
void init()
{
    N = MAXN;
    tol = 0;
    memset(head, -1, sizeof(head));
}
void addedge(int u, int v, int cap, int cost)//左端点,右端点,容量,花费
{
    edge[tol]. to = v;
    edge[tol]. cap = cap;
    edge[tol]. cost = cost;
    edge[tol]. flow = 0;
    edge[tol]. next = head[u];
    head[u] = tol++;
    edge[tol]. to = u;
    edge[tol]. cap = 0;
    edge[tol]. cost = -cost;
    edge[tol]. flow = 0;
    edge[tol]. next = head[v];
    head[v] = tol++;
}
bool spfa(int s, int t)
{
    queue<int>q;
    for(int i = 0; i < N; i++)
    {
        dis[i] = INF;
        vis[i] = false;
        pre[i] = -1;
    }
    dis[s] = 0;
    vis[s] = true;
    q.push(s);
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        vis[u] = false;
        for(int i = head[u]; i != -1; i = edge[i]. next)
        {
            int v = edge[i]. to;
            if(edge[i]. cap > edge[i]. flow &&
                    dis[v] > dis[u] + edge[i]. cost )
            {
                dis[v] = dis[u] + edge[i]. cost;
                pre[v] = i;
                if(!vis[v])
                {
                    vis[v] = true;
                    q.push(v);
                }
            }
        }
    }
    if(pre[t] == -1) return false;
    else return true;
}
//返回的是最大流, cost存的是最小费用
int minCostMaxflow(int s, int t, int &cost)
{
    int flow = 0;
    cost = 0;
    while(spfa(s,t))
    {
        int Min = INF;
        for(int i = pre[t]; i != -1; i = pre[edge[i^1]. to])
        {
            if(Min > edge[i]. cap - edge[i]. flow)
                Min = edge[i]. cap - edge[i]. flow;
        }
        for(int i = pre[t]; i != -1; i = pre[edge[i^1]. to])
        {
            edge[i]. flow += Min;
            edge[i^1]. flow -= Min;
            cost += edge[i]. cost * Min;
        }
        flow += Min;
    }
    return flow;
}

int main()
{
    int n, m;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0 && m==0)
            break;
        int ch = 0, cm = 0;
        init();//注意
        for(int i = 0; i < n; i++)
        {
            scanf("%s",map[i]);
            for(int j = 0; j < m; j++)
            {
                if(map[i][j]=='H')
                {
                    HH[ch].x = i;
                    HH[ch++].y = j;
                }
                else if(map[i][j]=='m')
                {
                    MM[cm].x = i;
                    MM[cm++].y = j;
                }
            }
        }
        //printf("ch:%d cm:%d\n",ch,cm);
        int beg = 0;//超级起点
        int end = 2*ch+1;//超级汇点
        for(int i = 0; i < cm; i++)
        {
            addedge(beg,i+1,1,0);//超级起点,容量为1,花费为0
            for(int j = 0; j < ch; j++)
            {
                int tt = abs(HH[i].x-MM[j].x)+abs(HH[i].y-MM[j].y);
                //printf("tt:%d\n",tt);
                addedge(i+1,j+1+ch,1,tt);
            }
            addedge(i+1+ch,end,1,0);//超级汇点容量为1,花费为0
        }
        int ans = 0;
        minCostMaxflow(beg,end,ans);
        printf("%d\n",ans);
    }
    return 0;
}



POJ 2195 & HDU 1533 Going Home(最小费用最大流)

标签:最小费用最大流   poj   hdu   

原文地址:http://blog.csdn.net/u012860063/article/details/41792973

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!