标签:poj2139
Six Degrees of Cowvin Bacon
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 3131 |
|
Accepted: 1455 |
Description
The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".
The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one ‘degree‘ away from the other. If a two cows have never worked together
but have both worked with a third cow, they are considered to be two ‘degrees‘ away from each other (counted as: one degree to the cow they‘ve worked with and one more to the other cow). This scales to the general case.
The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship
path exists between every pair of cows.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers
tell which cows were.
Output
* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.
Sample Input
4 2
3 1 2 3
2 3 4
Sample Output
100
Hint
[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]
Source
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
typedef long long LL;
#define maxn 302
#define inf 0x3f3f3f3f
int G[maxn][maxn], N, M;
int sta[maxn];
void Floyd(){
int i, j, k;
for(k = 1; k <= N; ++k)
for(i = 1; i <= N; ++i)
for(j = 1; j <= N; ++j)
if(G[i][k] + G[k][j] < G[i][j])
G[i][j] = G[i][k] + G[k][j];
}
int main() {
// freopen("stdin.txt", "r", stdin);
int i, j, num, ans = inf;
memset(G, 0x3f, sizeof(G));
scanf("%d%d", &N, &M);
for(i = 1; i <= N; ++i)
G[i][0] = G[i][i] = 0;
while(M--) {
scanf("%d", &num);
for(i = 0; i < num; ++i) {
scanf("%d", sta + i);
for(j = 0; j < i; ++j)
G[sta[i]][sta[j]] = G[sta[j]][sta[i]] = 1;
}
}
Floyd();
for(i = 1; i <= N; ++i) {
for(j = 1; j <= N; ++j)
G[i][0] += G[i][j];
if(ans > G[i][0]) ans = G[i][0];
}
printf("%d\n", ans * 100 / (N - 1));
return 0;
}
POJ2139 Six Degrees of Cowvin Bacon 【Floyd】
标签:poj2139
原文地址:http://blog.csdn.net/chang_mu/article/details/41677247