码迷,mamicode.com
首页 > 其他好文 > 详细

Quadtrees

时间:2014-12-08 21:26:59      阅读:222      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   ar   color   os   sp   for   

Description:


A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants, etc. In the quadtree, the image is represented by a parent node, while the four quadrants are represented by four child nodes, in a predetermined order.

Of course, if the whole image is a single color, it can be represented by a quadtree consisting of a single node. In general, a quadrant needs only to be subdivided if it consists of pixels of different colors. As a result, the quadtree need not be of uniform depth.

A modern computer artist works with black-and-white images of bubuko.com,布布扣 units, for a total of 1024 pixels per image. One of the operations he performs is adding two images together, to form a new image. In the resulting image a pixel is black if it was black in at least one of the component images, otherwise it is white.

This particular artist believes in what he calls the preferred fullness: for an image to be interesting (i.e. to sell for big bucks) the most important property is the number of filled (black) pixels in the image. So, before adding two images together, he would like to know how many pixels will be black in the resulting image. Your job is to write a program that, given the quadtree representation of two images, calculates the number of pixels that are black in the image, which is the result of adding the two images together.

In the figure, the first example is shown (from top to bottom) as image, quadtree, pre-order string (defined below) and number of pixels. The quadrant numbering is shown at the top of the figure.

bubuko.com,布布扣

Input Specification

The first line of input specifies the number of test cases (N) your program has to process.

The input for each test case is two strings, each string on its own line. The string is the pre-order representation of a quadtree, in which the letter ‘p‘ indicates a parent node, the letter ‘f‘ (full) a black quadrant and the letter ‘e‘ (empty) a white quadrant. It is guaranteed that each string represents a valid quadtree, while the depth of the tree is not more than 5 (because each pixel has only one color).

Output Specification

For each test case, print on one line the text ‘There are X black pixels.‘, where X is the number of black pixels in the resulting image.

Example Input

3
ppeeefpffeefe
pefepeefe
peeef
peefe
peeef
peepefefe

Example Output

There are 640 black pixels.
There are 512 black pixels.
There are 384 black pixels.
题意:给出的是程序的先序遍历;其中P是代表把张方形分成四份有黑色也有白色;e是白色,f是黑色;

<span style="font-size:14px;"># include <cstdio>
# include <cstring>
# include <iostream>
using namespace std;

char s[1050];    //存储字符串
int vis[40][40],cnt;      //将每个格子看成一个点;

void FILL(char *s,int &p,int r,int c,int w)     //将每个格子的左上角的坐标传递进去,还有长度;
{
    char ss=s[p++];     //将字符串取出;
    if(ss=='p')         //递归去读字符串;
    {
        FILL(s,p,r,c+w/2,w/2);
        FILL(s,p,r,c    ,w/2);
        FILL(s,p,r+w/2,c,w/2);
        FILL(s,p,r+w/2,c+w/2,w/2);
    }
    else if(ss=='f')     //将vis数组填充为黑色,即为1;
    {
        for(int i=r;i<r+w;i++)
            for(int j=c;j<c+w;j++)
        {
            if(vis[i][j]!=1)
            {
                vis[i][j]=1;    cnt++;
            }
        }
    }
}

int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        int i;
        cnt=0;
        memset(vis,0,sizeof(vis));
        for(i=0;i<2;i++)
        {
            int p=0;
            scanf("%s",s);
            FILL(s,p,0,0,32);
        }
        printf("There are %d black pixels.\n",cnt);
    }
    return 0;
}
</span>


Quadtrees

标签:des   style   http   io   ar   color   os   sp   for   

原文地址:http://blog.csdn.net/rechard_chen/article/details/41808059

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!