码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1028 Ignatius and the Princess III

时间:2014-12-08 22:44:14      阅读:200      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says. 

"The second problem is, given an positive integer N, we define an equation like this: 
  N=a[1]+a[2]+a[3]+...+a[m]; 
  a[i]>0,1<=m<=N; 
My question is how many different equations you can find for a given N. 
For example, assume N is 4, we can find: 
  4 = 4; 
  4 = 3 + 1; 
  4 = 2 + 2; 
  4 = 2 + 1 + 1; 
  4 = 1 + 1 + 1 + 1; 
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!" 
 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file. 
 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found. 
 

Sample Input

4 10 20
 

Sample Output

5 42 627
 
代码是zxp那搬来的 完全不明觉厉= =
bubuko.com,布布扣
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
__int64 a[150];
int main()
{
    int i,j;
    a[0]=1;//a[1]=1;a[2]=2;a[3]=3;a[4]=5;a[5]=7;
    for(i=1;i<=120;i++)
    {
        for(j=0;i+j<=120;j++)
        {
            a[i+j]+=a[j];
        }
    }
    int n;
    while(scanf("%d",&n)!=EOF)
    {
       printf("%I64d\n",a[n]);
    }
    return 0;
}
View Code

 

HDU 1028 Ignatius and the Princess III

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://www.cnblogs.com/sola1994/p/4151997.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!