码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ-1686 Oulipo ---KMP

时间:2014-12-08 23:09:37      阅读:362      评论:0      收藏:0      [点我收藏+]

标签:kmp   算法   

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5588    Accepted Submission(s): 2235


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.
 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

Sample Output
1 3 0
 
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
char s[1000010];
char t[10010];
int next[10010];
void get_next()
{
	int i=0;
	int j=-1;
	next[0]=-1;
	int len_t=strlen(t);
	while(i<len_t)
	{
		if(j==-1||t[i]==t[j])
		{
			i++;
			j++;
			if(t[i]==t[j])
			   next[i]=next[j];
		    else
			   next[i]=j;
		}
		else
		    j=next[j];
	}
}
int KMP()
{
	int i=-1;
	int j=-1;
	int len_t=strlen(t);
	int len_s=strlen(s);
	int count=0;
	get_next();
	while(i<len_s)
	{
		if(j==-1||s[i]==t[j])
		{
			i++;
			j++;
		}
		else
		{ 
		      j=next[j];
	    }
		if(j==len_t) //优化 
		{
			j=next[j];
			count++;
		} 
	}
	return count;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%s %s",t,s);
		printf("%d\n",KMP());
	}
	return 0; 
} 


HDOJ-1686 Oulipo ---KMP

标签:kmp   算法   

原文地址:http://blog.csdn.net/holyang_1013197377/article/details/41809741

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!