码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2136 Largest prime factor (筛选法求素数)

时间:2014-12-10 12:35:08      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:hdu   筛选法求素数   

Largest prime factor

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7297    Accepted Submission(s): 2589


Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
 

Input
Each line will contain one integer n(0 < n < 1000000).
 

Output
Output the LPF(n).
 

Sample Input
1 2 3 4 5
 

Sample Output
0 1 2 1 3
 

Author
Wiskey
 

题目大意:每个素数在素数表中都有一个序号,设1的序号为0,则2

的序号为1,3的序号为2,5的序号为3,以此类推。现在要求输出

给定的数n的最大质因子的序号,0<n<1000000。


#include<iostream>
#include<stdio.h>
using namespace std;
int pi;
bool flag[1000010];
int in;
int n;
int a[1000010];
int getprime()
{
    for(int i=2;i<1000010;++i)
    {
        if(!flag[i])
        {
            in++;
            for(int j=i;j<1000010;j+=i)
            {
                flag[j]=true;
                a[j]=in;//记录序号
            }
        }
    }
}
int main(int argc, char *argv[])
{
    //freopen("2136.in","r",stdin);
    getprime();
    while(scanf("%d",&n)!=EOF)
    {
        printf("%d\n",a[n]);
    }
    return 0;
}


HDU 2136 Largest prime factor (筛选法求素数)

标签:hdu   筛选法求素数   

原文地址:http://blog.csdn.net/wdkirchhoff/article/details/41844449

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!