码迷,mamicode.com
首页 > 其他好文 > 详细

FZU2107:Hua Rong Dao(DFS)

时间:2014-12-10 16:18:48      阅读:157      评论:0      收藏:0      [点我收藏+]

标签:fzu   dfs   

bubuko.com,布布扣 Problem Description

Cao Cao was hunted down by thousands of enemy soldiers when he escaped from Hua Rong Dao. Assuming Hua Rong Dao is a narrow aisle (one N*4 rectangle), while Cao Cao can be regarded as one 2*2 grid. Cross general can be regarded as one 1*2 grid.Vertical general can be regarded as one 2*1 grid. Soldiers can be regarded as one 1*1 grid. Now Hua Rong Dao is full of people, no grid is empty.

There is only one Cao Cao. The number of Cross general, vertical general, and soldier is not fixed. How many ways can all the people stand?

bubuko.com,布布扣 Input

There is a single integer T (T≤4) in the first line of the test data indicating that there are T test cases.

Then for each case, only one integer N (1≤N≤4) in a single line indicates the length of Hua Rong Dao.

bubuko.com,布布扣 Output

For each test case, print the number of ways all the people can stand in a single line.

bubuko.com,布布扣 Sample Input

212

bubuko.com,布布扣 Sample Output

018

bubuko.com,布布扣 Hint

Here are 2 possible ways for the Hua Rong Dao 2*4.

bubuko.com,布布扣



因为n最大为4,暴力搜索一下吧


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int d[4][2] = { {0, 0}, {0, 1}, {1, 0}, {1, 1} };
int dir[3][3][2] = { { {0, 1}, {0, 0} }, { {1, 0}, {0, 0} }, { {0, 0} } };
int cnt[3] = {2, 2, 1};
int r, v[5][5], tmp;
const int c = 4;
bool ok(int k, int x, int y)
{
    for (int i = 0; i< cnt[k]; i++)
    {
        int p = x + dir[k][i][0], q = y + dir[k][i][1];
        if (p<= 0 || p >r) return false;
        if (q<= 0 || q >c) return false;
        if (v[p][q]) return false;
    }
    return true;
}
void clear(int k, int x, int y, int t)
{
    for (int i = 0; i< cnt[k]; i++)
    {
        int p = x + dir[k][i][0], q = y + dir[k][i][1];
        v[p][q] = t;
    }
}
void dfs(int x, int y)
{
    if (y >c)	x = x + 1, y = 1;
    if (x == r + 1)
    {
        tmp++;
        return;
    }
    if (v[x][y]) dfs(x, y + 1);
    for (int i = 0; i< 3; i++)
    {
        if (ok(i, x, y))
        {
            clear(i, x, y, 1);
            dfs(x, y + 1);
            clear(i, x, y, 0);
        }
    }
}
int find(int x, int y)
{
    memset(v, 0, sizeof(v));
    for (int i = 0; i< 4; i++)
        v[x + d[i][0]][y + d[i][1]] = 1;
    tmp = 0;
    dfs(1,  1);
    return tmp;
}
int solve()
{
    int ans = 0;
    for (int i = 1; i< r; i++)
    {
        for (int j = 1; j< c; j++)
        {
            ans += find(i, j);
        }
    }
    return ans;
}
int main ()
{
    int t[10];
    for (r = 1; r<= 4; r++)
    {
        t[r] = solve();
    }
    int cas, n;
    scanf("%d", &cas);
    while (cas--)
    {
        scanf("%d", &n);
        printf("%d\n", t[n]);
    }
    return 0;
}


FZU2107:Hua Rong Dao(DFS)

标签:fzu   dfs   

原文地址:http://blog.csdn.net/libin56842/article/details/41847173

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!