标签:hdu 筛选素数
Max Factor
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3995 Accepted Submission(s): 1301
Problem Description
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular,
a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.
(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).
Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
Input
* Line 1: A single integer, N
* Lines 2..N+1: The serial numbers to be tested, one per line
Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
Sample Input
Sample Output
题目大意:给你N个数,求这N个数中哪个数的最大素因子最大,输出这个数,如果有多种结果,输出靠前边的那个数。
本例写的代码中prime具有二义性,但是这样能够减少空间利用
#include<iostream>
using namespace std;
int prime[20010];
int getprime()
{
prime[1]=1;
for(int i=2;i<20010;++i)
{
if(prime[i]==0)
{
for(int j=i;j<20010;j+=i)
{
prime[j]=i;
}
}
}
}
int main(int argc, char *argv[])
{
//freopen("2710.in", "r",stdin);
int MAX=0;
getprime();
int n;
int a;
int N;
while(scanf("%d",&n)!=EOF)
{
MAX=0;
while(n--){
scanf("%d",&a);
if(MAX<prime[a]){
MAX=prime[a];
N=a;
}
}
printf("%d\n",N);
}
return 0;
}
HDU 2710 Max Factor (筛选求素数)
标签:hdu 筛选素数
原文地址:http://blog.csdn.net/wdkirchhoff/article/details/41845879