码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3735 Training little cats(矩阵快速幂)

时间:2014-05-21 10:36:57      阅读:297      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   c   code   

Description

Facer‘s pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the cats to do his exercises. Facer‘s great exercise for cats contains three different moves:
g i : Let the ith cat take a peanut.
e i : Let the ith cat eat all peanuts it have.
s i j : Let the ith cat and jth cat exchange their peanuts.
All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea. 
You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them.

Input

The input file consists of multiple test cases, ending with three zeroes "0 0 0". For each test case, three integers nm and k are given firstly, where n is the number of cats and k is the length of the move sequence. The following k lines describe the sequence.
(m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have.

Sample Input

3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0

Sample Output

2 0 1

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

struct mat
{
    long long  t[101][101];
    void set()
    {
        memset(t,0,sizeof(t));
    }
}a,b;

mat multiple(mat a,mat b,int n)
{
    int i,j,k;
    mat temp;
    temp.set();
    for(i=0;i<=n;i++)
    for(j=0;j<=n;j++)
    {
        if(a.t[i][j])                          //普通解决方案会超时,这里
        for(k=0;k<=n;k++)                      //利用稀疏矩阵的特点进行优化
            temp.t[i][k]+=a.t[i][j]*b.t[j][k];
    }
    return temp;
}

mat quick_mod(mat b,int n,int m)
{
    mat a;
    a.set();
    for(int i=0;i<=n;i++) a.t[i][i]=1;
    while(m)
    {
        if(m&1)
        {
           a=multiple(a,b,n);
        }
        m>>=1;
        b=multiple(b,b,n);
    }
    return a;
}
void init(int n,int k)
{
    b.set();
    for(int i=0;i<=n;i++) b.t[i][i]=1;
    char s[2];
    int x,y;
    while(k--)
    {
        scanf("%s",s);
        if(s[0]=='g')
        {
          scanf("%d",&x);
          x--;
          b.t[x][n]++;
        }
        else if(s[0]=='s')
        {
            scanf("%d%d",&x,&y);
            x--,y--;
            for(int i=0;i<=n;i++)
            swap(b.t[x][i],b.t[y][i]);
        }
        else {
            scanf("%d",&x);
            x--;
            for(int i=0;i<=n;i++)
                b.t[x][i]=0;
        }
    }
    /*for(int i=0;i<=n;i++)
    {
        for(int j=0;j<=n;j++)
            cout<<b.t[i][j]<<" ";
        puts("");
    }
    */
}
int main()
{
    int n,m,k;
    while(cin>>n>>m>>k)
    {
        if(!n&&!m&&!k) break;
        init(n,k);
        a=quick_mod(b,n,m);
        for(int i=0;i<n;i++)
        cout<<a.t[i][n]<<" ";
        puts("");
    }
    return 0;
}


poj 3735 Training little cats(矩阵快速幂),布布扣,bubuko.com

poj 3735 Training little cats(矩阵快速幂)

标签:des   style   blog   class   c   code   

原文地址:http://blog.csdn.net/knight_kaka/article/details/26396261

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!