码迷,mamicode.com
首页 > 其他好文 > 详细

数据结构实验之链表四:有序链表的归并

时间:2014-12-11 06:46:01      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   ar   color   使用   sp   for   数据   

  数据结构实验之链表四:有序链表的归并

Time Limit: 1000MS Memory limit: 65536K

题目描述

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

输入

第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。

输出

输出合并后的单链表所包含的M+N个有序的整数。

示例输入

6 5
1 23 26 45 66 99
14 21 28 50 100

示例输出

1 14 21 23 26 28 45 50 66 99 100

提示

不得使用数组!

来源

 

示例程序

#include<stdio.h>
#include<stdlib.h>
struct node 
{
    int data;
    struct node *next;
};
//建立顺序链表
struct node *Creat(int n)
{
    struct node *head, *tail, *p;
    int i;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    for(i=1;i<=n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head;
}

struct node * Merge(struct node *head1, struct node *head2)
{
    struct node *p1, *p2, *tail;
    p1=head1->next;
    p2=head2->next;
    tail=head1;
    free(head2);
    while(p1&&p2)
    {
    if(p1->data < p2->data)
        {
            tail->next=p1;
            tail=p1;
            p1=p1->next;
        }
        else
        {
            tail->next=p2;
            tail=p2;
            p2=p2->next;
        }
    }
    if(p1)
        tail->next=p1;
    else
        tail->next=p2;
    return(head1);
}

int main()
{
    struct node * head1, *head2, *p;
    int n, m;
    scanf("%d %d",&n,&m);
    head1=Creat(n);
    head2=Creat(m);
    p=Merge(head1,head2);
    while(p->next->next!=NULL)
    {
        printf("%d ",p->next->data);
        p=p->next;
    }
    printf("%d\n",p->next->data);
    return 0;
}


数据结构实验之链表四:有序链表的归并

标签:des   style   io   ar   color   使用   sp   for   数据   

原文地址:http://blog.csdn.net/u013634961/article/details/41858745

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!