码迷,mamicode.com
首页 > 其他好文 > 详细

数据结构实验之链表五:单链表的拆分

时间:2014-12-11 06:49:12      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   ar   color   使用   sp   for   

  数据结构实验之链表五:单链表的拆分

Time Limit: 1000MS Memory limit: 65536K

题目描述

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

输入

第一行输入整数N;;
第二行依次输入N个整数。

输出

第一行分别输出偶数链表与奇数链表的元素个数;
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

示例输入

10
1 3 22 8 15 999 9 44 6 1001

示例输出

4 6
22 8 44 6 
1 3 15 999 9 1001

提示

不得使用数组!

来源

#include<stdio.h>
#include<stdlib.h>
struct node 
{
    int data;
    struct node *next;
};
struct node *Creat(int n)
{
    struct node *head, *tail, *p;
    int i;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    for(i=1;i<=n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=head->next;
        head->next=p;
    }
    return head;
}
struct node * Split(struct node * head1)
{
    struct node *head2, *p, *q;
    int a=0, b=0;
    head2=(struct node *)malloc(sizeof(struct node));
    head2->next=NULL;
    p=head1->next;
    head1->next=NULL;
    q=p->next;
    while(p!=NULL)
    {
        if(p->data%2==0)
        {
            p->next=head1->next;
            head1->next=p;
            a++;
        }
        else
        {
            p->next=head2->next;
            head2->next=p;
            b++;
        }
        p=q;
        if(q!=NULL)
        q=q->next;
    }
    printf("%d %d\n",a,b);
    return head2;
};
int main()
{
    int n;
    struct node * head1, *head, *p, *q;
    scanf("%d",&n);
    head=Creat(n);
    head1=Split(head);
    p=head->next;
    while(p!=NULL)
    {
        if(p->next!=NULL)
            printf("%d ",p->data);
        else
            printf("%d\n",p->data);
        p=p->next;
    }
    q=head1->next;
    while(q!=NULL)
    {
        if(q->next!=NULL)
            printf("%d ",q->data);
        else
            printf("%d\n",q->data);
        q=q->next;
    }
    return 0;
}


数据结构实验之链表五:单链表的拆分

标签:des   style   blog   io   ar   color   使用   sp   for   

原文地址:http://blog.csdn.net/u013634961/article/details/41858669

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!