码迷,mamicode.com
首页 > 其他好文 > 详细

UVA122 Trees on the level【二叉树】【BFS】

时间:2014-12-11 10:30:15      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   os   sp   for   

 Trees on the level 

Background
bubuko.com,布布扣
Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines‘ CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.

The Problem

Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.


In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree

picture28

is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L‘s and R‘s where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

The Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

The Output


For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete‘‘ should be printed.

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()


Sample Output


5 4 8 11 13 4 7 2 1

not complete


题目大意:输入一颗二叉树,将它按从上到下、从左到右的顺序输出各个节点位置。

思路:先根据输入的字符串将二叉树建立起来(注:可能出现不能建立的情况),若能

成功建立,则用宽度优先搜索(BFS)的方法遍历所有节点,并在遍历的时候,把结果

存下来,然后进行输出。

注意:BFS需要用到队列。


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<queue>
#include<vector>
using namespace std;

int flag = 1;
struct Node
{
    bool IsValue;
    int v;
    Node *left,*right;
    Node():IsValue(false),left(NULL),right(NULL){}
};

Node *root;
Node* newnode()
{
    return new Node();
}
void addnode(int v,char *s)
{
    int len = strlen(s);
    Node *u = root;
    for(int i = 0; i < len; i++)
    {
        if(s[i] == 'L')
        {
            if(u->left == NULL)
                u->left = newnode();
            u = u->left;
        }
        else if(s[i] == 'R')
        {
            if(u->right == NULL)
                u->right = newnode();
            u = u->right;
        }
    }
    if(u->IsValue)
        flag = 0;
    u->v = v;
    u->IsValue = true;
}
char s[300];
bool read_input()
{
    flag = 1;
    root = newnode();
    while(1)
    {
        if(scanf("%s",s)!=1)
            return false;
        if(!strcmp(s,"()"))
            break;
        int v;
        sscanf(&s[1],"%d",&v);
        addnode(v, strchr(s,',')+1);
    }
    return true;
}

bool bfs(vector<int>& ans)
{
    queue<Node*> q;
    ans.clear();
    q.push(root);
    while(!q.empty())
    {
        Node* u = q.front();
        q.pop();
        if(!u->IsValue)
            return false;
        ans.push_back(u->v);
        if(u->left != NULL)
            q.push(u->left);
        if(u->right != NULL)
            q.push(u->right);
    }
    return true;
}

int main()
{
    vector<int> ans;
    while(read_input())
    {
        if(!bfs(ans))
            flag = 0;
        if(flag==0)
            printf("not complete\n");
        else
        {
            for(int i = 0; i < ans.size(); i++)
            {
                if(i==ans.size()-1)
                    printf("%d\n",ans[i]);
                else
                    printf("%d ",ans[i]);
            }
        }
    }

    return 0;
}



UVA122 Trees on the level【二叉树】【BFS】

标签:des   style   blog   http   io   ar   os   sp   for   

原文地址:http://blog.csdn.net/lianai911/article/details/41862267

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!