码迷,mamicode.com
首页 > 其他好文 > 详细

UVA679 Dropping Balls【二叉树结点编号】

时间:2014-12-11 10:31:18      阅读:194      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   ar   os   sp   for   on   

  Dropping Balls 
A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf nodes of FBT. To determine a ball‘s moving direction a flag is set up in every non-terminal node with two values, either false or true. Initially, all of the flags are false. When visiting a non-terminal node if the flag‘s current value at this node is false, then the ball will first switch this flag‘s value, i.e., from the false to the true, and then follow the left subtree of this node to keep moving down. Otherwise, it will also switch this flag‘s value, i.e., from the true to the false, but will follow the right subtree of this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at 1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered from left to right.

For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1, 2, 3, ..., 15. Since all of the flags are initially set to be false, the first ball being dropped will switch flag‘s values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being dropped will switch flag‘s values at node 1, node 3, and node 6, and stop at position 12. Obviously, the third ball being dropped will switch flag‘s values at node 1, node 2, and node 5 before it stops at position 10.
bubuko.com,布布扣
Fig. 1: An example of FBT with the maximum depth 4 and sequential node numbers.

Now consider a number of test cases where two values will be given for each test. The first value is D, the maximum depth of FBT, and the second one is I, the Ith ball being dropped. You may assume the value of I will not exceed the total number of leaf nodes for the given FBT.

Please write a program to determine the stop position P for each test case.

For each test cases the range of two parameters D and I is as below: 


\begin{displaymath}2 \le D \le 20, \mbox{ and } 1 \le I \le 524288.
\end{displaymath}

Input 

Contains l+2 lines.

Line 1 I the number of test cases 
Line 2 $D_1 \ I_1$
test case #1, two decimal numbers that are separatedby one blank 
...  
Line k+1 $D_k \ I_k$
test case #k 
Line l+1 $D_l \ I_l$
test case #l 
Line l+2 -1 a constant -1 representing the end of the input file


Output 


Contains l lines.

Line 1 the stop position P for the test case #1 
...  
Line k the stop position P for the test case #k 
...  

Line l the stop position P for the test case #l


Sample Input 

5
4 2
3 4
10 1
2 2
8 128

-1


Sample Output 

12
7
512
3
255

Miguel Revilla 

2000-08-14


题目大意:给一颗深度为D的完全二叉树,节点编号从上到下从左到右为1,2,3,4……

在结点1上方一个小球,小球落到一个结点上就会改变该点的开关。若该点开,则向

左走,否则向右走,给你I个小球,问最后一个小球最后所能落到的叶子编号。

思路:每一个结点上第奇数个小球都落在左子树上,第偶数个小球都落在右子树上。

直接对最后一个小球判断就可以了。若I为该结点奇数,它是向左走的第(I+1)/2个小球。

若为偶数,则是向右走的I/2个小球。


#include<stdio.h>
#include<string.h>

int main()
{
    int D,I,N;
    while(~scanf("%d",&N) && N!=-1)
    {
        while(N--)
        {
            int k = 1;
            scanf("%d%d",&D,&I);
            for(int i = 1; i < D; i++)
            {
                if(I&1)
                {
                    k <<= 1;
                    I = (I+1)>>1;
                }
                else
                {
                    k = (k<<1|1);
                    I >>= 1;
                }
            }
            printf("%d\n",k);
        }
    }

    return 0;
}




UVA679 Dropping Balls【二叉树结点编号】

标签:des   style   http   io   ar   os   sp   for   on   

原文地址:http://blog.csdn.net/lianai911/article/details/41862051

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!