码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2677(双调旅行商问题<bictonicTSP>

时间:2014-05-21 08:24:18      阅读:354      评论:0      收藏:0      [点我收藏+]

标签:动态规划   struct   printf   algorithm   dp   

                                                                                                   Tour
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3470 Accepted: 1545

Description

John Doe, a skilled pilot, enjoys traveling. While on vacation, he rents a small plane and starts visiting beautiful places. To save money, John must determine the shortest closed tour that connects his destinations. Each destination is represented by a point in the plane pi = < xi,yi >. John uses the following strategy: he starts from the leftmost point, then he goes strictly left to right to the rightmost point, and then he goes strictly right back to the starting point. It is known that the points have distinct x-coordinates. 
Write a program that, given a set of n points in the plane, computes the shortest closed tour that connects the points according to John‘s strategy.

Input

The program input is from a text file. Each data set in the file stands for a particular set of points. For each set of points the data set contains the number of points, and the point coordinates in ascending order of the x coordinate. White spaces can occur freely in input. The input data are correct.

Output

For each set of data, your program should print the result to the standard output from the beginning of a line. The tour length, a floating-point number with two fractional digits, represents the result. An input/output sample is in the table below. Here there are two data sets. The first one contains 3 points specified by their x and y coordinates. The second point, for example, has the x coordinate 2, and the y coordinate 3. The result for each data set is the tour length, (6.47 for the first data set in the given example).

Sample Input

3
1 1
2 3
3 1
4
1 1
2 3
3 1
4 2

Sample Output

6.47
7.89


#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstdio>
#define INF 0x3f3f3f3f
const int maxn=10001;
using namespace std;

double dp[maxn][maxn],dis[maxn][maxn];
int n;

struct Point{
    int x;
    int y;
}p[maxn];

bool cmp(Point a,Point b)
{
    return a.x<b.x;
}

double cal(Point a,Point b)
{
    return sqrt((double)(a.x-b.x)*(a.x-b.x)+(double)(a.y-b.y)*(a.y-b.y));
}


double bitonicTSP()
{
    int i,j;
    dp[0][0]=0;
    dp[1][0]=dis[0][1];        //initial  dis[0][1]不是dis[1][0]

    for(i=1;i<n-1;i++)
    {
        dp[i+1][i]=INF;
        for(j=0;j<i;j++)
        {
            dp[i+1][j]=dp[i][j]+dis[i][i+1];
            dp[i+1][i]=min(dp[i+1][i],dp[i][j]+dis[j][i+1]);

        }
    }

    return dp[n-1][n-2]+dis[n-2][n-1];
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        scanf("%d%d",&p[0].x,&p[0].y);
        if(n==1) {printf("0.00\n");continue;}

        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&p[i].x,&p[i].y);
        }

        sort(p,p+n,cmp);
        for(int i=0;i<n-1;i++)
            for(int j=i+1;j<n;j++)
            {
                dis[i][j]=cal(p[i],p[j]);          //注意这里,我的代码,要求dis[i][j],i<j,
            }

        printf("%.2lf\n",bitonicTSP());

    }
    return 0;

}

(表示确实很难理解!bubuko.com,布布扣

具体思想,欢迎大家看:http://blog.csdn.net/code_or_code/article/details/26283159




POJ 2677(双调旅行商问题<bictonicTSP>,布布扣,bubuko.com

POJ 2677(双调旅行商问题<bictonicTSP>

标签:动态规划   struct   printf   algorithm   dp   

原文地址:http://blog.csdn.net/code_or_code/article/details/26387829

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!