码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1837 Balance

时间:2014-05-21 07:23:20      阅读:312      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   c   code   

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 10065   Accepted: 6231

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm‘s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
? the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
? the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-‘ for the left arm and ‘+‘ for the right arm); 
? on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights‘ values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

一个天平有若干个挂钩和砝码,求把砝码全用上的使天平平衡的方法数目。

因为位置有负值,而15*20*25=7500,所以可以令dp[0][7500]=1,(j=7500代表平衡状态)

状态转移方程为:dp[i][j+g[i]*c[k]]+=dp[i-1][j];   即达到当前状态的数目有多少。

#include"stdio.h"
#include"string.h"
#define mmin(a,b) ((a)<(b)?(a):(b))
#define N 15005
int dp[22][N];
int main()
{
    int i,j,k,n,m;
    int c[25],g[25];
    while(scanf("%d%d",&n,&m)!=-1)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&c[i]);
        }
        for(i=1;i<=m;i++)
        {
            scanf("%d",&g[i]);
        }
        memset(dp,0,sizeof(dp));
        dp[0][7500]=1;    //不挂砝码时平衡状态有一种
        for(i=1;i<=m;i++)
        {
            for(j=0;j<N;j++)
            {
                if(dp[i-1][j]==0)     //该状态不可达
                    continue;
                for(k=1;k<=n;k++)
                {
                    dp[i][j+g[i]*c[k]]+=dp[i-1][j];     
                }
            }
        }
        printf("%d\n",dp[m][7500]);
    }
    return 0;
}





poj 1837 Balance,布布扣,bubuko.com

poj 1837 Balance

标签:des   style   blog   class   c   code   

原文地址:http://blog.csdn.net/u011721440/article/details/26372083

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!