码迷,mamicode.com
首页 > 其他好文 > 详细

中缀式变后缀式

时间:2014-12-11 20:55:53      阅读:212      评论:0      收藏:0      [点我收藏+]

标签:style   io   ar   color   os   使用   sp   for   on   

中缀式变后缀式

时间限制:1000 ms  |  内存限制:65535 KB
难度:3
描述
人们的日常习惯是把算术表达式写成中缀式,但对于机器来说更“习惯于”后缀式,关于算术表达式的中缀式和后缀式的论述一般的数据结构书都有相关内容可供参看,这里不再赘述,现在你的任务是将中缀式变为后缀式。
输入
第一行输入一个整数n,共有n组测试数据(n<10)。
每组测试数据只有一行,是一个长度不超过1000的字符串,表示这个运算式的中缀式,每个运算式都是以“=”结束。这个表达式里只包含+-*/与小括号这几种符号。其中小括号可以嵌套使用。数据保证输入的操作数中不会出现负数。
数据保证除数不会为0
输出
每组都输出该组中缀式相应的后缀式,要求相邻的操作数操作符用空格隔开。
样例输入
2
1.000+2/4=
((1+2)*5+1)/4=
样例输出
1.000 2 4 / + =
1 2 + 5 * 1 + 4 / =
代码:
#include<stdio.h>
int main()
{
	int T,i,top;
	char str[1005],ch[1005];
	scanf("%d",&T);
	while(T--)
	{
		scanf("%s",str);
		top=-1;
		for(i=0;str[i]!=‘\0‘;i++)
		{
			if(str[i]>=‘0‘&&str[i]<=‘9‘)
			{
				while((str[i]==‘.‘)||(str[i]>=‘0‘&&str[i]<=‘9‘))
				{
					printf("%c",str[i]);
					i++;
				}
				printf(" ");
			}
			if(str[i]==‘=‘)
				break;
			if(str[i]==‘)‘)
			{
				while(top>=0&&(ch[top]!=‘(‘))
				{
					printf("%c ",ch[top]);
					top--;
				}
				top--;
			}
			else if(str[i]==‘(‘)
			{
				top++;
				ch[top]=str[i];
			}
			else if(str[i]==‘*‘||str[i]==‘/‘)
			{
				while((ch[top]==‘*‘)||(ch[top]==‘/‘))
				{
					printf("%c ",ch[top]);
					top--;
				}
				top++;
				ch[top]=str[i];
			}
			else
			{
				while(top>=0&&(ch[top]!=‘(‘))
				{
					printf("%c ",ch[top]);
					top--;
				}
				top++;
				ch[top]=str[i];
			}
		}
		while(top>=0)
		{
			printf("%c ",ch[top]);
			top--;
		}
		printf("=\n");
	}
	return 0;
}

中缀式变后缀式

标签:style   io   ar   color   os   使用   sp   for   on   

原文地址:http://blog.csdn.net/qq_16997551/article/details/41871063

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!