码迷,mamicode.com
首页 > 其他好文 > 详细

剑指offer系列源码-左旋转字符串

时间:2014-12-11 22:31:12      阅读:246      评论:0      收藏:0      [点我收藏+]

标签:blog   io   ar   os   sp   on   数据   2014   art   

题目1362:左旋转字符串(Move!Move!!Move!!!)
时间限制:2 秒内存限制:32 兆特殊判题:否提交:1577解决:669
题目描述:
汇编语言中有一种移位指令叫做循环左移(ROL),现在有个简单的任务,就是用字符串模拟这个指令的运算结果。对于一个给定的字符序列S,请你把其循环左移K位后的序列输出。例如,字符序列S=”abcXYZdef”,要求输出循环左移3位后的结果,即“XYZdefabc”。是不是很简单?OK,搞定它!
输入:
多组测试数据,每个测试数据包含一个字符序列S和非负整数K。其中S的长度不超过1000。
输出:
对应每个测试案例,输出新序列。
样例输入:
UDBOJ 4
abba 1
样例输出:
JUDBO
bbaa


输入的k可能大于字符串长度,故做取余操作。

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
void reverseStr(char* begin,char*end){
    if(begin==NULL||end==NULL){
        return;
    }
    while(begin<end){
        swap(*begin,*end);
        begin++;
        end--;
    }
}
char* leftRotateString(char* pData,int n){
    if(pData!=NULL){
        int length =strlen(pData);
        if(length>0&&n>0&&n<length){
            char* pFirstStart = pData;
            char* pFirstEnd = pData+n-1;
            char* pSecondStart = pData+n;
            char* pSecondEnd = pData+length-1;
            reverseStr(pFirstStart,pFirstEnd);
            reverseStr(pSecondStart,pSecondEnd);
            reverseStr(pFirstStart,pSecondEnd);
        }
    }
    return pData;
}
int main()
{
    char data[1001];
    int n;
    while(scanf("%s%d",data,&n)!=EOF){
        printf("%s\n",leftRotateString(data,n%strlen(data)));
    }
     return 0;
}


剑指offer系列源码-左旋转字符串

标签:blog   io   ar   os   sp   on   数据   2014   art   

原文地址:http://blog.csdn.net/hackcoder/article/details/41874287

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!