RIPv1基本配置
拓扑结构:
实验步骤1:路由器基本IP配置
R1基本配置:
R1(config)#int lo0
R1(config-if)#ip add 1.1.1.1 255.255.255.0
R1(config-if)#int s1/0
R1(config-if)#ip add 192.168.12.1255.255.255.0
R1(config-if)#no shut
R2基本配置:
R2(config)#int s1/0
R2(config-if)#ip add 192.168.12.2255.255.255.0
R2(config-if)#no shut
R2(config-if)#int s1/1
R2(config-if)#ip add 192.168.23.2255.255.255.0
R2(config-if)#no sh
R3基本配置:
R3(config)#int s1/0
R3(config-if)#ip add 192.168.23.3255.255.255.0
R3(config-if)#no sh
R3(config-if)#int s1/1
R3(config-if)#ip add 192.168.34.3255.255.255.0
R3(config-if)#no sh
R4基本配置:
R4(config)#int s1/0
R4(config-if)#ip add 192.168.34.4255.255.255.0
R4(config-if)#no sh
R4(config-if)#int lo0
R4(config-if)#ip add 4.4.4.4 255.255.255.0
实验步骤2:RIP路由通告
R1配置:
R1(config)#router rip //启动RIP进程
R1(config-router)#network 1.1.1.1 //network命令通告各接口路由,注意RIPv1是classfull协议
R1(config-router)# network 192.168.12.0
R2配置:
R2(config-if)#router rip
R2(config-router)#network 192.168.12.0
R2(config-router)#network 192.168.23.0
R3配置:
R3(config)#router rip
R3(config-router)#network 192.168.23.0
R3(config-router)#network 192.168.34.0
R4配置:
R4(config-if)#router rip
R4(config-router)#network 192.168.34.0
R4(config-router)#netwo 4.4.4.4
实验调试:
R1#showip rout //查看R1路由表
C 192.168.12.0/24 is directly connected, Serial1/0 //R1直连路由,通过S1/0接口
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0 //环回口直连路由
R 4.0.0.0/8 [120/1] via 192.168.12.2,00:00:21, Serial1/0 //通过RIP学习到A类路由
R 192.168.23.0/24 [120/1] via 192.168.12.2, 00:00:21, Serial1/0 //通过RIP学习C类路由
R 192.168.34.0/24 [120/1] via 192.168.12.2, 00:00:21, Serial1/0 //通过RIP学习C类路由
路由条目“4.0.0.0/8 [120/1] via 192.168.12.2, 00:00:21, Serial1/0”的含义如下:
① R:路由条目是通过 RIP 路由协议学习来的;
② 4.0.0.0/8:目的网络;
③ 120:RIP 路由协议的默认管理距离;
④1: 度量值,从路由器 R1 到达网络 4.0.0.0/8 的度量值为1 跳;//问题来了,怎么只有1跳?
⑤ 192.168.12.2:下一跳地址;//相邻路由器接口的IP地址
⑥ 00:00:03:距离下一次更新还有 27(30-3)秒;
⑦ Serial1/0:接收该路由条目的本路由器R1的接口。
R1#show ip protocols //查看R1路由协议
Routing Protocol is "rip"//路由器上运行的路由协议是 RIP
Outgoing update filter list for all interfaces is not set //在出方向上没有设置过滤列表
Incoming update filter list for all interfaces is not set //在入方向上没有设置过滤列表
Sending updates every 30 seconds, next due in 22 seconds //更新周期是 30 秒,距离下次更新还有 23秒
Invalid after 180 seconds, hold down 180, flushed after 240 //无效时间、抑制时间和刷新时间
Redistributing: rip //只运行 RIP 协议,没有其它的协议重分布进来
Default version control: send version 1, receive any version //默认发送版本 1 的路由更新,接收本版 1 的路由更新
Interface Send Recv Triggered RIP Key-chain
Serial1/0 1 1 2
Loopback0 1 1 2
//以上三行显示了运行 RIP协议的接口,以及可以接收和发送的 RIP 路由更新的版本
Automatic network summarization is in effect //RIP 路由协议默认开启自动汇总功能
Maximum path: 4 //RIP 路由协议可以支持 4 条等价路径,最大为 6 条
Routing for Networks:
1.0.0.0
192.168.12.0
//以上三行表明 RIP 通告的网络
Routing Information Sources:
Gateway Distance Last Update
192.168.12.2 120 00:00:13
Distance: (default is 120)
//以上三行表明路由信息源,其中:
//gateway:学习路由信息的路由器的接口地址,也就是下一跳地址
//distance:管理距离
//last update:更新发生在多长时间以前
Distance: (default is 120)
//默认管理距离是 120
【注意】为了防止更新同步,RIP 会以 15%的误差发送更新,即实际发送更新的周期的范围是
25.5-30 秒。//老师在上课时候提到该注意点。
R1#debug ip rip //该命令可以查看 RIP 路由协议的动态更新过程。
Dec12 11:08:00.615: RIP: sending v1 update to 255.255.255.255 via Serial1/0(192.168.12.1)
*Dec12 11:08:00.615: RIP: build update entries
*Dec12 11:08:00.615: network 1.0.0.0 metric1
R1#
*Dec12 11:08:09.095: RIP: received v1 update from 192.168.12.2 on Serial1/0
*Dec12 11:08:09.095: 4.0.0.0 in 1 hops
*Dec12 11:08:09.099: 192.168.23.0 in 1hops
*Dec12 11:08:09.099: 192.168.34.0 in 1hops
R1#debugip rip
*Dec12 11:08:18.631: RIP: sending v1 update to 255.255.255.255 via Loopback0(1.1.1.1)
*Dec12 11:08:18.631: RIP: build update entries
*Dec12 11:08:18.631: network 4.0.0.0 metric1
*Dec12 11:08:18.635: network 192.168.12.0metric 1
*Dec12 11:08:18.635: network 192.168.23.0metric 1
*Dec12 11:08:18.635: network 192.168.34.0metric 1 //可以看到 RIPv1 采用广播更新(255.255.255.255),分别向 Loopback0和 s0/0/0 发送路由更新,同时从 s0/0/0 接收三条路由更新,分别是 4.0.0.0,度量值是 1跳;192.168.34.0, 度量值是 1 跳;192.168.23.0,度量值是 1 跳。这里有问题的?
【flash update】flash update(闪式更新)指的是当网络上某个路径的度量值发生变化,路由器立即发出更新信息,而不管是否到达常规路由信息更新的周期。
学习心得:
路由协议如何启动进程;
router rip、network *.*.*.*操作命令及其作用;
路由表含义;
调试命令:show ip route、show ip protocols、debug ip rip,这些命令我常常忘记。
本文出自 “Batman” 博客,请务必保留此出处http://5740675.blog.51cto.com/5730675/1589149
原文地址:http://5740675.blog.51cto.com/5730675/1589149