码迷,mamicode.com
首页 > 其他好文 > 详细

HDU - 2817 - A sequence of numbers (快速幂取模!)

时间:2014-12-14 10:43:03      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:hdu   快速幂取模   c++   acm   icpc   

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3494    Accepted Submission(s): 1073


Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 

Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 

Output
Output one line for each test case, that is, the K-th number module (%) 200907.
 

Sample Input
2 1 2 3 5 1 2 4 5
 

Sample Output
5 16
 

Source



题意:就是给出数列的前三个数,判断是否是等差或是等比,然后算出第k个数,注意算等比时要用快速幂取模(还要注意溢出问题,最好全用long long,我没注意WA了两次%>_<%)


 arithmetic or geometric sequences.  等差数列或等比数列


AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <iostream>
#include <cstdlib>
#define LL long long
using namespace std;

const int maxn = 200907;

int qmod(LL a, LL q, int m)
{
	LL ans = a%maxn;
	while(m)
	{
		if(m&1) ans = (ans*q)%maxn;
		q = ((q%maxn*q%maxn)%maxn);
		m>>=1;
	}
	return (int)(ans%maxn);
}

int main()
{
	int N, k;
	LL a, b, c;
	scanf("%d", &N);
	while(N--)
	{
		scanf("%I64d %I64d %I64d %d", &a, &b, &c, &k);
		if(b-a == c-b)
		{
			LL cha = b-a;
			printf("%d\n", (int)( ( (k-3) * cha + c) % maxn) );
		}
		else 
		{
			LL bi = b/a;
			printf("%d\n", qmod(a, bi, k-1));
		}
	}
	return 0;
} 


HDU - 2817 - A sequence of numbers (快速幂取模!)

标签:hdu   快速幂取模   c++   acm   icpc   

原文地址:http://blog.csdn.net/u014355480/article/details/41923555

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!