码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ3623:Battle Ships(完全背包)

时间:2014-12-15 23:40:22      阅读:304      评论:0      收藏:0      [点我收藏+]

标签:zoj   dp   

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes tiseconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases. 
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers i(1 ≤ i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input

1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output

2
4
5

题意:
对方有L滴血,我们有n种船可以选择,每种船建造时间为t,建好后每秒对敌方造成l点伤害,问最少多少时间能干掉对方

思路:
以时间为容量来进行背包

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define inf 1<<30
int dp[10000],t[100],l[100];

int main()
{
    int n,m,i,j,sum = 6600,ans;
    while(~scanf("%d%d",&n,&m))
    {
        for(i = 0; i<n; i++)
            scanf("%d%d",&t[i],&l[i]);
        memset(dp,0,sizeof(dp));
        for(j = 0; j<333; j++)
        {
            for(i = 0; i<n; i++)
            {
                dp[j+t[i]] = max(dp[j+t[i]],dp[j]+j*l[i]);
            }
        }
        ans = inf;
        for(i = 0; i<333; i++)
        {
            if(dp[i]>=m)
            {
                ans=min(ans,i);
            }
        }
        printf("%d\n",ans);
    }

    return 0;
}


ZOJ3623:Battle Ships(完全背包)

标签:zoj   dp   

原文地址:http://blog.csdn.net/libin56842/article/details/41950961

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!