码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2178

时间:2014-12-16 06:26:22      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   ar   io   os   sp   java   strong   

猜数字

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3487    Accepted Submission(s): 2512


Problem Description
A有1数m,B来猜.B每猜一次,A就说"太大","太小"或"对了" 。 
问B猜n次可以猜到的最大数。 
 

 

Input
第1行是整数T,表示有T组数据,下面有T行 
每行一个整数n (1 ≤ n ≤ 30) 
 

 

Output
猜n次可以猜到的最大数
 

 

Sample Input
2 1 3
 

 

Sample Output
1 7
 

 

Author
Zhousc
 

 

Source
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<queue>
#include<set>
#include<vector>
using namespace std;
int t,n;
int main()
{
      scanf("%d",&t);
      while(t--)
      {
            scanf("%d",&n);
            printf("%d\n",(1<<n)-1);
      }
      return 0;
}

  

hdu 2178

标签:des   blog   http   ar   io   os   sp   java   strong   

原文地址:http://www.cnblogs.com/a972290869/p/4166244.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!