码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1496

时间:2014-12-16 06:31:02      阅读:217      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   ar   io   os   sp   for   java   

Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5663    Accepted Submission(s): 2253


Problem Description
Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

 

Output
For each test case, output a single line containing the number of the solutions.
 

 

Sample Input
1 2 3 -4 1 1 1 1
 

 

Sample Output
39088 0
 

 

Author
LL
 

 

Source
 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<set>
using namespace std;
int a,b,c,d;
int hash1[3000010],ans;
int main()
{
      while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF)
      {
            ans=0;
            memset(hash1,0,sizeof(hash1));
            if((a>0&&b>0&&c>0&&d>0)||(a<0&&b<0&&c<0&&d<0))
            {
                  printf("0\n");
                  continue;
            }
            for(int x1=1;x1<101;x1++)
                  for(int x2=1;x2<101;x2++)
                        hash1[a*x1*x1+b*x2*x2+2000000]++;
            for(int x3=1;x3<101;x3++)
                  for(int x4=1;x4<101;x4++)
                        ans+=hash1[2000000-c*x3*x3-d*x4*x4];
            ans=ans*16;
            printf("%d\n",ans);
      }
      return 0;
}

  

hdu 1496

标签:des   blog   http   ar   io   os   sp   for   java   

原文地址:http://www.cnblogs.com/a972290869/p/4166256.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!