码迷,mamicode.com
首页 > 其他好文 > 详细

【POJ 1655】Balancing Act 【树的重心】

时间:2014-12-16 17:11:15      阅读:193      评论:0      收藏:0      [点我收藏+]

标签:poj   树的重心   oi   acm   

Balancing Act
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9241   Accepted: 3846

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T. 
For example, consider the tree: 
bubuko.com,布布扣

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two. 

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number. 

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

Source


求树的重心。


任意选一个点为root,进行dfs,找到最大儿子最小的那个结点即可。


#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
int tot=0,ans1,n,ans2,h[20005],T,son[20005];
struct edge
{
	int y,ne;
}a[100005];
void Addedge(int x,int y)   //前向星也挺好写的,以后不用vector了
{
	tot++;
	a[tot].y=y;
	a[tot].ne=h[x];
	h[x]=tot;
}
void Dfs(int x)
{
	int i=h[x],now=0;
	son[x]=0;
	while (i)
	{
		int y=a[i].y;
		if (son[y]==-1) 
		{
			Dfs(y);
	 	    son[x]=son[x]+son[y]+1;
		    if (son[y]+1>now) now=son[y]+1;
		}
		i=a[i].ne;
	}
	if (now<n-1-son[x]) now=n-1-son[x];
	if (now==ans1&&ans2>x) ans2=x;
	if (now<ans1)
		ans1=now,ans2=x;
}
int main()
{
    scanf("%d",&T);
	while (T--)
	{
		scanf("%d",&n);
		tot=0;
		for (int i=1;i<=n;i++)
			h[i]=0;
		for (int i=1;i<n;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			Addedge(x,y);
			Addedge(y,x);
		}
		for (int i=1;i<=n;i++)
			son[i]=-1;
		ans1=ans2=n;
		Dfs(1);
		printf("%d %d\n",ans2,ans1);
	}
	return 0;
}

bubuko.com,布布扣

【POJ 1655】Balancing Act 【树的重心】

标签:poj   树的重心   oi   acm   

原文地址:http://blog.csdn.net/regina8023/article/details/41961583

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!