码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 572 - Oil Deposits (图的DFS!)

时间:2014-12-16 22:47:56      阅读:629      评论:0      收藏:0      [点我收藏+]

标签:uva   数据结构   图论   dfs   traversal   

UVA - 572

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

bubuko.com,布布扣


  Oil Deposits 

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise bubuko.com,布布扣 and bubuko.com,布布扣. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ` *‘, representing the absence of oil, or ` @‘, representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output 

0
1
2
2



Miguel A. Revilla
1998-03-10

Source

Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 4. Graph :: Depth First Search :: Finding Connected Components / Flood Fill

Root :: AOAPC II: Beginning Algorithm Contests (Second Edition) (Rujia Liu) :: Chapter 6. Data Structures :: Examples
Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 2. Data Structures :: Graphs
Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Graph :: Graph Traversal :: Flood Fill/Finding Connected Components
Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Graph :: Graph Traversal :: Flood Fill/Finding Connected Components


利用DFS,然后递归即可


AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm> 
using namespace std;

char map[105][105];
int vis[105][105];

void dfs(int i, int j)
{
	if(map[i][j] == '*' || vis[i][j]) return;
	vis[i][j] = 1;
	dfs(i-1, j-1); dfs(i-1, j);  dfs(i-1, j+1);
	dfs(i, j-1); 				 dfs(i, j+1);
	dfs(i+1, j-1); dfs(i+1, j);  dfs(i+1, j+1);
}

int main()
{
	int m, n;
	while(scanf("%d %d", &m, &n), m || n)
	{
		memset(vis, 0, sizeof(vis));   //所有格子都没访问过 
		for(int i=0; i<105; i++)     //初始化图的外沿为‘*’ 
		{
			for(int j=0; j<105; j++)
			{
				map[i][j] = '*';
			}
		}
		char a[105];
		for(int i=1; i<=m; i++)    //输入 
		{
			scanf("%s", a);
			for(int j=1; j<=n; j++)
			{
				map[i][j] = a[j-1];
			}
		}
		int count = 0;
		for(int i=1; i<=m; i++)    //DFS的应用 
		{
			for(int j=1; j<=n; j++)
			{
				if(!vis[i][j] && map[i][j] == '@')
				{
					count++;
					dfs(i, j);
				}
			}
		}
		printf("%d\n", count);
	}
	return 0;
}


UVA - 572 - Oil Deposits (图的DFS!)

标签:uva   数据结构   图论   dfs   traversal   

原文地址:http://blog.csdn.net/u014355480/article/details/41966281

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!