码迷,mamicode.com
首页 > 其他好文 > 详细

swust oj 方程式(0300)

时间:2014-12-17 12:27:56      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   ar   io   color   sp   for   on   

Description

Consider equations having the following form: a*x1*x1 + b*x2*x2 + c*x3*x3 + d*x4*x4 = 0 a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0. It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}. Determine how many solutions satisfy the given equation.

Input

The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.

Output

or each test case, output a single line containing the number of the solutions.

Sample InpUT
 
1 2 3 -4
1 1 1 1
 
Sample Output
 
39088
0
 
#include<stdio.h>
struct pz
{
    int x;
}book1[1000000],book2[1000000];
int main()
{
    int a,b,c,d;
    while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF){
        if((a > 0 && b > 0 && c > 0 && d > 0) || (a < 0 && b < 0 && c < 0 && d < 0))
        {
            printf("0\n");
            continue;
      }
    int x;
    int i,j;
    for(i=1;i<=100;i++)
        for(j=1;j<=100;j++){
            x=a*i*i+b*j*j;
            if(x>0)
                book1[x].x++;
            else
                book2[-x].x++;
        //  printf("%d %d\n",book1[k-1],book2[k-1]);
        }
        int ans=0;
        for(i=1;i<=100;i++)
            for(j=1;j<=100;j++){
                x=-(c*i*i+d*j*j);
                if(x>0)
                    ans+=book1[x].x;
                    else
                    ans+=book2[-x].x;
            }
            printf("%d\n",ans*4*4);
        for(i=0;i<1000000;i++){
        book1[i].x=0;
        book2[i].x=0;
    }
    }
    return 0;
}

 

swust oj 方程式(0300)

标签:des   style   blog   ar   io   color   sp   for   on   

原文地址:http://www.cnblogs.com/yanglingwell/p/4168883.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!