标签:dp
Treats for the Cows
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 4234 |
|
Accepted: 2132 |
Description
FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.
The treats are interesting for many reasons:
- The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
- Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
- The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
- Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?
The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input
Line 1: A single integer, N
Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output
Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
5
1
3
1
5
2
Sample Output
43
Hint
Explanation of the sample:
Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).
FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.
Source
USACO 2006 February Gold & Silver
区间dp,考虑[i, j]这一段,假设其他的都还没拿出来,那么[i, j] 一定由 [i + 1, j] 或者 [i, j - 1] 推得
dp[i][j] = max(dp[i + 1][j] + v[i] * (n - (j - i)), dp[i][j - 1] + v[j] * (n - (j - i)))
#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 2010;
int dp[N][N];
int val[N];
int main()
{
int n;
while(~scanf("%d", &n))
{
memset (dp, 0, sizeof(dp));
for (int i = 1; i <= n; ++i)
{
scanf("%d", &val[i]);
dp[i][i] = val[i];
}
for (int i = n; i >= 1; --i)
{
for (int j = i; j <= n; ++j)
{
dp[i][j] = max(dp[i + 1][j] + val[i] * (n - (j - i + 1) + 1), dp[i][j - 1] + val[j] *(n - (j - i + 1) + 1) );
}
}
printf("%d\n", dp[1][n]);
}
return 0;
}
POJ3186——Treats for the Cows
标签:dp
原文地址:http://blog.csdn.net/guard_mine/article/details/41984107