码迷,mamicode.com
首页 > 其他好文 > 详细

Ordering Tasks

时间:2014-12-17 21:00:12      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:des   style   ar   io   os   sp   for   strong   on   

Description

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.


Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.


Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.


Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3

题意:按拓扑排序输出;


<span style="font-size:14px;"># include <cstdio>
# include <cstring>
# include <iostream>
using namespace std;

int dp[1100][1100],vis[1100],ans[1100],n,m,t;

bool dfs(int i)
{
    vis[i]=-1;
    for(int j=1;j<=n;j++)    if(dp[i][j])    //判断两者是否联通
    {
        if(vis[j]<0)    return false;        //判断是否出现环
        else  if(!vis[j])    dfs(j);         //继续深搜
    }
    vis[i]=1;   ans[t--]=i;                  //标记
    return true;
}

bool toposort()     //以每一个点开始深搜;
{
    t=n;
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
        if(!vis[i])    if(!dfs(i))    return false;
    return true;
}

int main()
{
    //freopen("a.txt","r",stdin);
    while(cin>>n>>m&&n)
    {
        int i,x,y;
        memset(dp,0,sizeof(dp));
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&x,&y);
            dp[x][y]=1;
        }
        if(toposort())
        {
            for(i=1;i<n;i++)
                printf("%d ", ans[i]);
            printf("%d\n", ans[n]);
        }
        else    printf("No\n");
    }
    return 0;
}</span>


Ordering Tasks

标签:des   style   ar   io   os   sp   for   strong   on   

原文地址:http://blog.csdn.net/rechard_chen/article/details/41985651

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!