码迷,mamicode.com
首页 > 其他好文 > 详细

Charlie's Change(完全背包+路径记忆)

时间:2014-12-17 23:57:16      阅读:245      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   ar   io   color   os   sp   

Charlie‘s Change

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 3176   Accepted: 913

Description

Charlie is a driver of Advanced Cargo Movement, Ltd. Charlie drives a lot and so he often buys coffee at coffee vending machines at motorests. Charlie hates change. That is basically the setup of your next task. 

Your program will be given numbers and types of coins Charlie has and the coffee price. The coffee vending machines accept coins of values 1, 5, 10, and 25 cents. The program should output which coins Charlie has to use paying the coffee so that he uses as many coins as possible. Because Charlie really does not want any change back he wants to pay the price exactly. 

Input

Each line of the input contains five integer numbers separated by a single space describing one situation to solve. The first integer on the line P, 1 <= P <= 10 000, is the coffee price in cents. Next four integers, C1, C2, C3, C4, 0 <= Ci <= 10 000, are the numbers of cents, nickels (5 cents), dimes (10 cents), and quarters (25 cents) in Charlie‘s valet. The last line of the input contains five zeros and no output should be generated for it.

Output

For each situation, your program should output one line containing the string "Throw in T1 cents, T2 nickels, T3 dimes, and T4 quarters.", where T1, T2, T3, T4 are the numbers of coins of appropriate values Charlie should use to pay the coffee while using as many coins as possible. In the case Charlie does not possess enough change to pay the price of the coffee exactly, your program should output "Charlie cannot buy coffee.".

Sample Input

12 5 3 1 2
16 0 0 0 1
0 0 0 0 0

Sample Output

Throw in 2 cents, 2 nickels, 0 dimes, and 0 quarters.
Charlie cannot buy coffee.


题意:给定一个数p,要求用四种币值为1,5,10,25的硬币拼成p,并且硬币数要最多,如果无解输出"Charlie cannot buy coffee.",1<=p<=1万,1<=硬币数量<=1万
思路:完全背包+路径记忆。
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
int v[4]= {1,5,10,25};
int dp[10010];
int path[10010],used[10010];
int num[4];
int ans[100];//这个要大于25
int main()
{
 //   freopen("in.txt","r",stdin);
//   freopen("out.txt","w",stdout);
    int P;
    while(scanf("%d%d%d%d%d",&P,&num[0],&num[1],&num[2],&num[3]),(P+num[0]+num[1]+num[2]+num[3]))
    {
        for(int i=0; i<=P; i++)dp[i]=-INF;
        memset(path,0,sizeof(path));

        path[0]=-1;//退出的条件
        dp[0]=0;
        for(int i=0; i<4; i++)
        {
            memset(used,0,sizeof(used));
            for(int j=v[i]; j<=P; j++)
            {
                if(dp[j-v[i]]+1>dp[j]&&dp[j-v[i]]>=0&&used[j-v[i]]<num[i])
                {
                    //dp[j]存j里用多少枚硬币换。(要多的);used来记录是否超过数量
                    dp[j]=dp[j-v[i]]+1;//压入dp,
                    used[j]=used[j-v[i]]+1;//体积j,里数量加一
                    path[j]=j-v[i];//记录上一个路径(体积)
                }
  //              printf("dp[%d]=%d \t used[%d]=%d\tpath[%d]=%d\n",j,dp[j],j,used[j],j,path[j]);
            }
        }

        if(dp[P]<0)
        {
            printf("Charlie cannot buy coffee.\n");
            continue;
        }

        memset(ans,0,sizeof(ans));
        int i=P;
        while(1)
        {
            if(path[i]==-1)break;
            ans[i-path[i]]++;
            i=path[i];
        }
        printf("Throw in %d cents, %d nickels, %d dimes, and %d quarters.\n",ans[v[0]],ans[v[1]],ans[v[2]],ans[v[3]]);

    }
    return 0;
}
/*
12 5 3 1 2
16 0 0 0 1
0 0 0 0 0
*/

 

不懂看看测试数据;
bubuko.com,布布扣
是不是很清楚了。。哈哈。

Charlie's Change(完全背包+路径记忆)

标签:des   style   blog   http   ar   io   color   os   sp   

原文地址:http://www.cnblogs.com/yuyixingkong/p/4170567.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!