码迷,mamicode.com
首页 > 其他好文 > 详细

九度OJ 1042 Coincidence (动态规划求最长公共子序列)

时间:2014-12-18 01:42:32      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:九度oj   1042   

题目1042:Coincidence

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:1689

解决:898

题目描述:

Find a longest common subsequence of two strings.

输入:

First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.

输出:

For each case, output k – the length of a longest common subsequence in one line.

样例输入:
abcd
cxbydz
样例输出:
2

求两串的最长公共子序列,算导上的动态规划例子:

#include<stdio.h>
#include<string.h>
char a[101];
char b[101];
int c[101][101];
int i,j;
void lcs(){
    int ans=0;
    int m=strlen(a);
    int n=strlen(b);
    memset(c,0,sizeof(c));
    for(i=0;i<m;++i)
        c[i][0]=0;
    for(i=0;i<n;++i)
        c[0][i]=0;
    for(i=1;i<=m;++i)
        for(j=1;j<=n;++j)
        {
            if(a[i-1]==b[j-1])
            {
                c[i][j]=c[i-1][j-1]+1;
            }
            else if(c[i-1][j]>=c[i][j-1]){
                c[i][j]=c[i-1][j];
            }
            else
            {
                c[i][j]=c[i][j-1];
            }
        }
    printf("%d\n",c[m][n]);
}
int main(int argc, char *argv[])
{
    while(~scanf("%s%s",a,b))
    {
        lcs();
    }
    return 0;
}


九度OJ 1042 Coincidence (动态规划求最长公共子序列)

标签:九度oj   1042   

原文地址:http://blog.csdn.net/wdkirchhoff/article/details/41982917

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!